Page MenuHomePhabricator

cross-wiki notifications: after clicking 'View changes' - 'There are no notifications' is displayed.
Closed, ResolvedPublic

Description

  1. With enabled cross-wiki notification leave a message/create a new section on a wikitext User talk page.
  2. In a different wiki, a user receives a notification about their User talk page changes:

  1. Clicking on 'View changes' - 'Difference between revisions ...' page is displayed.
  2. Returning (browser back button) will display.

Event Timeline

Etonkovidova updated the task description. (Show Details)
Etonkovidova raised the priority of this task from to Needs Triage.
Etonkovidova added a project: Notifications.
Etonkovidova added a subscriber: Etonkovidova.
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptFeb 16 2016, 1:03 AM
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald Transcript

I think this is part of a more general bug: if the foreign notifications item changes (wikis are added/removed, numbers change) but the foreign notifications item has already been rendered ones, the UI isn't updated even after it re-fetches this information.

Change 279428 had a related patch set uploaded (by Mooeypoo):
[wip] Update notifications when reopening the popup

https://gerrit.wikimedia.org/r/279428

This is currently blocked on a bug that already exists but is exposed more with the current fix.

When notification bundles are updated, their ID is different, which means that there is no way for the code to tell that the bundle already exists in the list and should be changed. Instead, the popup adds another (redundant) notification as it is new.

Change 279428 merged by jenkins-bot:
Update notifications when reopening the popup

https://gerrit.wikimedia.org/r/279428

Checked the fix in betalabs. The issue is not present anymore.

jmatazzoni closed this task as Resolved.Apr 8 2016, 7:03 PM