Page MenuHomePhabricator

CompletionSuggester Beta Feature broken on Hebrew Wikipedia
Closed, ResolvedPublic

Description

The completion suggester beta feature on the Hebrew Wikipedia returns zero suggestions when enabled.

First reported by User:קיפודנח

ש: https://www.mediawiki.org/wiki/Help:CirrusSearch/CompletionSuggester#currently_broken_on_hewiki

Steps to reproduce:

  1. Visit https://he.wikipedia.org
  2. Log in
  3. Enable the beta feature
    1. For non hebrew-reading folks: https://he.wikipedia.org/wiki/מיוחד:העדפות#mw-prefsection-betafeatures is the link to the beta features preference pane.
    2. The completion suggester is the first checkbox.
  4. Search for something.
    1. My example is the phrase "Breaking Bad" or "שובר שורות"
  5. Nothing is suggested.

Disabling the beta feature and searching shows suggestions.

Event Timeline

CKoerner_WMF raised the priority of this task from to Needs Triage.
CKoerner_WMF updated the task description. (Show Details)
CKoerner_WMF added a project: Discovery.
CKoerner_WMF added a subscriber: CKoerner_WMF.
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptFeb 17 2016, 6:47 PM
Deskana triaged this task as High priority.Feb 17 2016, 7:15 PM
Deskana added a subscriber: Kipod.
Deskana added a subscriber: Deskana.

Not quite "Unbreak now!" because this is a beta feature, but it is still very high priority for us to fix.

Users were asked to disable the feature. If it isn't fixed in the near future I would suggest to disable the beta feature so users will not get bad impression.

dcausse claimed this task.Feb 17 2016, 10:04 PM

The index was not created properly, I will investigate. This is maybe due to the rolling restart last week. I created T127182 to make this process more robust.
I've updated it manually so it should work properly now.
I will double check other indices tomorrow.

dcausse closed this task as Resolved.Feb 17 2016, 10:07 PM
dcausse moved this task from In Progress to Done on the Discovery-Search (Current work) board.

Thanks @dcausse!

@CKoerner_WMF Perhaps you could reach out to the Hebrew users informing them that we fixed the issue and that it was a temporary one which should never occur in a full release? I'm sure one of our Hebrew speakers (e.g. @Amire80, @Mooeypoo. @Smalyshev, etc.) would be willing to assist with a one-off English to Hebrew translation, if that would be helpful.

@eranroz Thanks! Works for me too with beta enabled now.

@eranroz Awesome! Thank you so much!

Kipod added a comment.Feb 19 2016, 7:53 PM

may be a good idea to fallback on "old" suggestions if CompletionSuggester returns empty list, regardless of the reason (software bug, broken index, some server is down, whatever), at least as long as the "old" suggestions still available..

peace.