Page MenuHomePhabricator

cross-wiki: If a user sees Alerts and marks as read Messages in local wikis, then the cross-wiki bundle displays 'There are no notifications'
Closed, ResolvedPublic

Description

  1. A user with 'Enhanced notifications' enabled logs in to A wiki and sees in Notifications panel messages from B wiki.
  2. Without marking them as read, he goes to B wiki and opens the Notification panel there and Mark those messages as read.
  3. Logging back to wiki A a user would see in expanded cross-wiki bundle - 'There are no notifications' .


The same is with Alerts - except, of course, that Alerts have to be just be open in local wiki, then cross-wiki bundle for Alerts will show 'There are no notifications' .

Event Timeline

Etonkovidova raised the priority of this task from to Needs Triage.
Etonkovidova updated the task description. (Show Details)
Etonkovidova added a project: Notifications.
Etonkovidova added a subscriber: Etonkovidova.
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald Transcript

I think this is by design.

The cross-wiki notifications only shows unread notifications from a foreign wiki. After you do those things, the foreign wiki notifications are no longer unread.

In T127242#2036987, @Mattflaschen wrote:

I think this is by design.
The cross-wiki notifications only shows unread notifications from a foreign wiki. After you do those things, the foreign wiki notifications are no longer unread.

I think you misunderstand the report. The final screenshot in the task description shows a cross-wiki bundle that, when opened, shows "There are no notifications". This should never happen. I first theorized that this could have been caused by marking those notifs as read on wiki B after opening the popup on wiki A but before expanding the bundle, but Elena told me that's not what she did: even if she performs the steps in sequence, it still happens. Looking at the database for her user in beta labs, I believe this is caused by T127331: Unread count in echo_unread_wikis cannot go back to zero.

That said, we may want to do something better when we open a cross-wiki bundle and find there are no notifications left.

Re-checked with T127331: Unread count in echo_unread_wikis cannot go back to zero - whether that fix also fixed this issue - the bug exists.

Checked in betalabs - the issue is fixed.

Etonkovidova closed this task as Resolved.Feb 29 2016, 5:24 PM