Page MenuHomePhabricator

Phabricator errors when filing new Maniphest task (due to "Can Edit Task Policies" policy for application Maniphest)
Closed, ResolvedPublic

Description

Since the most recent Phabricator upgrade, when I go to https://phabricator.wikimedia.org/maniphest/task/edit/form/1/ to try to file a new Maniphest task, if I fill in the title and description fields and submit the form, I get the following error message from Phabricator:

Access Denied: Maniphest	
You do not have permission to edit task policies.
Users with the "Can Edit Task Policies" capability:
This object has a custom policy controlling who can take this action.

Other Phabricator users can apparently file tasks.

I'm not touching any of the "Visible To" fields or any other fields in the form besides "Title" and "Description". I tried logging out and logging back in and the same error persisted.

I can edit existing tasks.

Event Timeline

Dzahn created this task.Feb 18 2016, 2:51 AM
Restricted Application added subscribers: StudiesWorld, Luke081515, scfc, Aklapper. · View Herald TranscriptFeb 18 2016, 2:51 AM
MZMcBride renamed this task from Leah gets Access Denied: Maniphest ? to Leah gets Access Denied: Maniphest :-(.Feb 18 2016, 2:51 AM
MZMcBride renamed this task from Leah gets Access Denied: Maniphest :-( to Phabricator errors when filing (creating) a new Maniphest task.Feb 18 2016, 2:55 AM
MZMcBride updated the task description. (Show Details)
This comment was removed by Joergi123.

I'm having this problem too.

It also happends to everything too.

Dzahn added a comment.Feb 18 2016, 3:02 AM

I don't have this problem and already created new tasks after the upgrade and i'm not a phabricator admin.

The "Visible To" fields are now gone from the Maniphest task creation form. And when I go to create a Maniphest task, it's now working for me.

mmodell closed this task as Resolved.Feb 18 2016, 3:15 AM
mmodell claimed this task.

@MZMcBride: Indeed, it's fixed. :) Sorry about that everyone, I had to reconfigure some things manually after the upgrade - some of the new features aren't configured through files that can be managed by puppet.

Dalba added a subscriber: Dalba.Jun 16 2018, 6:22 AM
Dalba reopened this task as Open.Jun 16 2018, 6:47 AM

Sorry for reviving an old task. But I can't create any new tasks and I'm getting the same error as in the description. Can anyone help?

Sorry for reviving an old task. But I can't create any new tasks and I'm getting the same error as in the description. Can anyone help?

I assuming its a badly thought out antispam measure, I've added you to Trusted-Contributors to allow you to create tasks

Thank you, @Peachey88! I can create new tasks now. I'm leaving this task open for Phab admins to decide if it requires further investigation or can be closed.

@Dalba: Can you please provide exact steps to reproduce and explicitly include full URL links?
I don't have problems to access https://phabricator.wikimedia.org/maniphest/task/edit/form/1/ with my default volunteer Phab account...

Others reported this issue as well. From #mediawiki:

[11:16:56] <aharoni> Hallo.
[11:17:06] <aharoni> I cannot create a Phabricator task.
[11:18:08] <p858snake> aharoni: whats your phab username?
[11:18:09] <aharoni> I am trying to create a task with the UniversalLanguageSelector tag, and I get an error:
[11:18:15] <aharoni> Access Denied: Maniphest You do not have permission to edit task policies. Users with the "Can Edit Task Policies" capability:      This object has a custom policy controlling who can take this action.
[11:18:24] <aharoni> Username: Amire80

@Aklapper, I cannot reproduce it now that I am in Trusted-Contributors group, but before that, I could easily reproduce it by going to https://phabricator.wikimedia.org/maniphest/task/edit/form/1/, filling the title and description both with test and then clicking on Create New Task button.

I suspect that it has been related to https://phabricator.wikimedia.org/feed/6567474271514543638/ and https://phabricator.wikimedia.org/feed/6567627488554519074/ and is now fixed.

Aklapper renamed this task from Phabricator errors when filing (creating) a new Maniphest task to Phabricator errors when filing new Maniphest task (due to "Can Edit Task Policies" policy for application Maniphest).Jun 18 2018, 1:14 PM
Aklapper closed this task as Resolved.