Page MenuHomePhabricator

Phabricator does not list project addition anymore on task creation (in the UI and mail notifications)
Closed, ResolvedPublic

Description

Upon creation of T127281, email was received

Legoktm created this task.
Herald added subscribers: StudiesWorld, Aklapper.
TASK DESCRIPTION
I'm lazy, and it would be nice if the OOUI demos had a link to the jsduck docs somewhere.

Upon creation of T126786, email was received

matmarex created this task.
matmarex added a subscriber: matmarex.
matmarex added a project: OOjs-UI.
Herald added subscribers: StudiesWorld, Aklapper.
TASK DESCRIPTION
Calling debounced updateThemeClasses multiple times per widget might be slow? I'm seeing it pop up all over the place in Chrome dev tools profiler. We're setting up and then removing several timers when constructing some widgets with many mixins (e.g. ButtonWidget), not sure how bad this is.

For watchers of the OOUI project, it is not instantly clear why the first email was received.

Event Timeline

Restricted Application added subscribers: StudiesWorld, Luke081515, scfc, Aklapper. · View Herald TranscriptFeb 18 2016, 6:48 AM

The mail headers for T127281 list X-Phabricator-Projects: <#oojs-ui> but indeed it's not instantly clear.

Aklapper renamed this task from Phabricator not reporting projects added on task creation to Phabricator notification mail does not list project anymore added on task creation.Feb 18 2016, 9:20 AM
Aklapper triaged this task as Low priority.
Ricordisamoa added a comment.EditedFeb 18 2016, 9:31 AM

Aklapper changed the title from "Phabricator not reporting projects added on task creation" to "Phabricator notification mail does not list project anymore added on task creation".

Not only notification mail. Look at this task via web: I do see Phabricator in Projects but not in the changes.

Aklapper triaged this task as "Low" priority.

Why? You can see it should be High because otherwise it will keep sending silly emails.

Aklapper renamed this task from Phabricator notification mail does not list project anymore added on task creation to Phabricator does not list project addition anymore on task creation (in the UI and mail notifications).Feb 18 2016, 1:25 PM

Not only notification mail. Look at this task via web: I do see Phabricator in Projects but not in the changes.

Oh. Thanks. Adjusted the task summary.

Aklapper triaged this task as "Low" priority.

Why? You can see it should be High because otherwise it will keep sending silly emails.

Could you elaborate? Whether you receive an email is unrelated to whether the project is visibly listed or not. If you refer to "It's harder for me to find out why I received that email", that would be https://secure.phabricator.com/T6297 I guess.

Could you elaborate? Whether you receive an email is unrelated to whether the project is visibly listed or not. If you refer to "It's harder for me to find out why I received that email", that would be https://secure.phabricator.com/T6297 I guess.

https://secure.phabricator.com/T6297 would be a great feat, but project additions should be notified regardless of their relevance to the notification.

Could you answer T127282#2039245 please?

Could you answer T127282#2039245 please?

I get lots of Phabricator notifications from many different projects daily. In order to be effective I must be able to assess them in a timely manner. Without projects I can hardly make sense out of them.

scfc added a comment.Feb 18 2016, 6:59 PM

Personally, I sort Phabricator notifications into folders by the header X-Phabricator-Projects mentioned by @Aklapper. The folders roughly correspond to projects that I am more interested in and a catch-all. So when I enter mail.wikimedia.tools I know that any Phabricator notification there will be related to Toolforge.

This is a huge functional regression for me. :(

I can no longer easily identify new tasks that are in Security or a MW extension I watch or something I was explicitly cc'd on (usually higher priority).

X-Phabricator-Projects doesn't really work for me because tasks are often filed against multiple projects.

This is a huge functional regression for me. :(

+1 here too. When a new task is created, there's no mention of the associated projects in the e-mail body, which means I have to either (a) click on the link to see which projects the task is about; or (b) look at the source of the e-mail to see the headers. Both of those make my workflow less effective.

I can no longer easily identify new tasks that are in Security or a MW extension I watch or something I was explicitly cc'd on (usually higher priority).
X-Phabricator-Projects doesn't really work for me because tasks are often filed against multiple projects.

GMail doesn't allow automatic filtering based on arbitrary headers, so the header is more or less useless for me :/

This is a pain for me as well. Lets upstream this issue?

This is a pain for me as well. Lets upstream this issue?

Done: https://secure.phabricator.com/T10493

mmodell added a comment.EditedMar 2 2016, 6:48 PM

Upstream response: this was mostly intentional, however, they didn't wontfix it so there is hope :)

Ideas for a better way of doing this might be helpful and I can aggregate everyone's feedback in the upstream task if we come up with some good ideas here.

Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptMay 17 2016, 6:21 PM

Fixed upstream. I'll try to get this deployed today.

mmodell closed this task as Resolved.May 19 2016, 1:27 AM
mmodell claimed this task.

Upon creation of T135758, email was received

Kipod created this task.
Herald added subscribers: Zppix, Aklapper.
TASK DESCRIPTION
(Recent report from hewiki user):
recently, hovercards text on hewiki is displayed left-aligned.
inspecting the HTML, i see:

<a dir="he" lang="rtl" class="mwe-popups-extract" href="/wiki/%D7%AA%D7%9C%D7%9E%D7%95%D7%93">

instead of the expected

lang="he" dir="rtl"

peace.

Ricordisamoa reopened this task as Open.May 23 2016, 11:18 PM
Aklapper closed this task as Resolved.Jun 12 2016, 5:31 PM

This is fixed now (according to the bugmail I receive).

Oh, it's not fixed in the web UI though, but I personally consider that less relevant...