Page MenuHomePhabricator

mr1-ulsfo booted from backup JunOS
Closed, ResolvedPublic

Description

After mr1-ulsfo's powercycling (due to T127094), it came back with the backup JunOS image, due to unknown reasons so far (possible corruption?). This needs investigating and fixing, especially since the backup image was a very old JunOS version.

Event Timeline

faidon created this task.Feb 18 2016, 11:15 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 18 2016, 11:15 AM

Mentioned in SAL [2016-02-18T11:29:12Z] <paravoid> mr1-ulsfo: "request system snapshot media internal slice alternate" + reboot (T127295)

Mentioned in SAL [2016-02-18T11:36:22Z] <paravoid> upgrading mr1-ulsfo to its pre-recovery version and rebooting (T127295)

faidon closed this task as Resolved.Feb 18 2016, 12:10 PM

I did the following:

  • request system snapshot media internal slice alternate to reformat the primary partition in case it was corrupted
  • request system reboot, which booted from the primary partition again (now with the old 11.4R8.4)
  • request system software add ... reboot, to upgrade to its previously well-known version (12.1X46-D35.1), which booted successfully into the new version again
  • request system snapshot media internal slice alternate to reformat the alternate slice with the current JunOS version.

Additionally I ran request system snapshot media internal slice alternate to mr1-eqiad/codfw/esams, to avoid such a downgrade happening on our other SRXes as well.