Page MenuHomePhabricator

MobileFrontend's wikitext editor fails to refresh the page after editing a section and saving
Closed, ResolvedPublic0 Story Points

Description

  1. Click edit on https://en.m.wikipedia.org/wiki/Wikipedia:Gather/Gather_RFC_proposal_-_February_2016 or any other page.
  2. Make an edit with the wikitext editor and hit save.
  3. The page doesn't refresh with my changes.
  4. Hit F5/refresh and the changes appear.

Expected: The changes should appear straight away on save.

Event Timeline

Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptFeb 19 2016, 6:21 PM

This is still an issue.
@Jdforrester-WMF I would say this is a high priority thing to fix as it is highly confusing. I expect there is an error somewhere in the stack.
Are we confident this is not impacting edit numbers in mobile?

Jdlrobson triaged this task as High priority.May 30 2016, 9:06 PM

I hit this again today.
The console says "A pending toast message already exits. The page should have been reloaded by now."
Again I thought my edit had failed without useful feedback.

@Jdforrester-WMF and @dr0ptp4kt need to have a chat about this and work out who's going to fix this.

Jdlrobson changed the task status from Open to Stalled.

I tried to reproduce this on master and en.wiki
But it does refresh with newly added content for me . Which browser were you using ?

Jdforrester-WMF renamed this task from Editing a page doesn't refresh the page to Reports of MobileFrontend's wikitext editor fails to refresh the page after saving.Jun 8 2016, 2:37 PM
Jdforrester-WMF updated the task description. (Show Details)

Is this a regression or did it never work?

Off the top of my head, March-ish was roughly when the work by @Florian on a new wikitext editor on MF was merged; was it known to operate before then? Pinging Florian in case he knows and has fixed this since then. :-)

(Also, yeah, I can't reproduce on Beta Cluster with iOS Safari 9.3 and Android 4.4 in both mVE and mWT.)

Hmm, I don't remember that I've changed the editor in MF recently (this year) :/ However, I can't reproduce this problem :(

I looked at the code that handles the reload, and as far as the execution goes to the point where the toast should be saved (the "The console says "A pending toast message already exits. The page should have been reloaded by now."" error message indicates this), there's nearly no magic code that could fail without any error message/exception. (The toast warning itself is a warning only and shouldn't interrupt or prevent the reload/save process, however, this shouldn't happen at all).

@Jdlrobson: Can you reproduce the problem whenever you edit a page or is it sporadic?

This still happens to me I'd say about 80% of the time on my Nexus 5. I'm editing as a logged in user.

Jdlrobson changed the task status from Stalled to Open.Nov 29 2016, 11:20 PM

I

Jdlrobson changed the task status from Open to Stalled.Nov 29 2016, 11:23 PM
Jdlrobson claimed this task.

Obviously now Im unable to replicate this when I specifically try to ;-) I'll keep an eye on this and if i hit it again I'll debug this like crazy. I suspect what's happening is under some circumstances the window.location call gets overidden by something else (e.g. window.history.back executed by overlay) and as a result the page doesn't refresh and thus the toast doesn't show.

Jdlrobson removed Jdlrobson as the assignee of this task.Dec 7 2016, 7:07 PM
Jdlrobson changed the task status from Stalled to Open.

FInallyyyy! A replication step.
Visit https://en.m.wikivoyage.org/wiki/User:Jdlrobson/%C5%8Ckunoshima
Click edit icon next to GGG heading
Enter some content
Hit save.

This happens for me every single time. ie. it only impacts section edit links.
@Ryasmeen can you confirm?

@Jdlrobson yes I was able to reproduce as well on https://en.m.wikipedia.beta.wmflabs.org/wiki/User:RYasmeen_(WMF)/sandbox.

It happens when I open wikitext editor by clicking on section edit link not when I click the edit icon for the lead section of that page.

Jdlrobson renamed this task from Reports of MobileFrontend's wikitext editor fails to refresh the page after saving to MobileFrontend's wikitext editor fails to refresh the page after editing a section and saving.Feb 6 2017, 11:47 PM
Jdlrobson added a project: VisualEditor.

This bug continues to plague me and put me off editing so preparing a fix for it as I'm sure I'm not alone... review appreciated as it should be easy to fix.

Change 336339 had a related patch set uploaded (by Jdlrobson):
Actually reload the page when hash is included

https://gerrit.wikimedia.org/r/336339

Change 336339 merged by jenkins-bot:
Actually reload the page when hash is included

https://gerrit.wikimedia.org/r/336339

Jdlrobson closed this task as Resolved.Feb 8 2017, 12:13 AM
Jdlrobson claimed this task.

I've verified this is fixed on beta cluster. Happy happy joy joy.
https://en.m.wikipedia.beta.wmflabs.org/wiki/Headings#Heading_level_1

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptFeb 8 2017, 12:13 AM
Ryasmeen edited projects, added Verified; removed Patch-For-Review.Feb 8 2017, 6:46 PM
Jdforrester-WMF set the point value for this task to 0.Feb 8 2017, 11:18 PM
Ryasmeen moved this task from To be Verified to Verified on the User-Ryasmeen board.