Page MenuHomePhabricator

Using New-Section link on any Talk page blanks entire page
Closed, InvalidPublic

Description

I just tried to add a New-Section to [[WP:TOTD]] talk using https://en.wikipedia.org/w/index.php?title=Wikipedia_talk:Tip_of_the_day&action=edit&section=new and when I clicked on the Changes button in the Edit window it indicated it was going to blank the whole page except for my adds.

Event Timeline

Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptFeb 19 2016, 10:37 PM
Checkingfax triaged this task as High priority.Feb 19 2016, 10:39 PM

When you clicked on the 'Show Changes' button, it decided to remove the whole existing page apart from your additions?

UPDATE: I just verified it by clicking on New-Section, then clicking on the Changes button before making any changes and it blanks the page. Cheers!

Krenair, the button is "Changes" not "Show changes", but yes, when I made an entry it the Changes window showed me that the whole page was going to be blanked except my adds.

Also, my new paragraphs from the New-Section were seemingly randomly interspersed in snippets throughout the whole pre-existing page. I use wikEdDiff to view changes in a wide, integrated view.

Normally the Changes button only shows the section that is being edited, not the whole page.

Housekeeping regarding Tasks here:
1.- How do I edit a comment I submitted? I know how to edit the task itself, but how to edit my comments?
2.- Didn't comments here used to be threaded so comments were more germane to their topic?

Checkingfax renamed this task from Adding New-Section on TOTD Talk page blanks entire page to Using New-Section link on TOTD Talk page blanks entire page.Feb 19 2016, 11:04 PM

UPDATE: Just tested it on a User talk page and the New-section link blanks the whole page there too when you click on the Changes button:

https://en.wikipedia.org/w/index.php?title=User_talk:Corinne&action=edit&section=new

Aklapper raised the priority of this task from High to Needs Triage.Feb 19 2016, 11:09 PM

UPDATE: I used an Edit-source link and was able to add content to the TOTD Talk page without blanking the page. I clicked on the Changes button mid-way to confirm I was not going to nuke the page.

Aklapper, how is changing the Priority level of this task from "High" to "Needs triage" a raising of priority? Just trying to understand the Phabricator Task priority process.

Also, what does "backlog" mean?

If everybody's Talk page is going to be blanked when new sections are added, this is going to be a hot mess to clean up.

Checkingfax renamed this task from Using New-Section link on TOTD Talk page blanks entire page to Using New-Section link on any Talk page blanks entire page.Feb 19 2016, 11:15 PM

UPDATE: Just tested it on a User talk page and the New-section link blanks the whole page there too when you click on the Changes button:
https://en.wikipedia.org/w/index.php?title=User_talk:Corinne&action=edit&section=new

I can't reproduce with those steps, using Chrome, Safari, Firefox or Opera (latest all). Can you tell me what browser(s)/platform(s) you're using on which you're finding this issue?

how is changing the Priority level of this task from "High" to "Needs triage" a raising of priority? Just trying to understand the Phabricator Task priority process.

Maybe triage is a really high priority for upstream, just below UBN

Also, what does "backlog" mean?

Usually stuff that needs triaging lives here

MediaWiki's "Show changes" button gives me the right result:

But when I click the icon (from wikEdDiff gadget), I indeed get the result you describe:

Is that what you're seeing? If so, this should probably be reported at https://en.wikipedia.org/wiki/User_talk:Cacycle/wikEdDiff. If not, please provide screenshots, so that we can tell what you're talking about :)

Also – this seems to only affect the displayed diff. Saving the change does not actually blank the page, does it?

I was afraid to save the page but I guess I could and then do a revert if it actually blanks the page.

Using Firefox 44.0.2 and Windows 7 Professional 64-bit

Yes, I see the apparent blanking intention in the wikEdDiff view as I originally stated.

Same issue in Google Chrome Version 48.0.2564.116 m in wikEdDiff view.

TTO closed this task as Invalid.Feb 20 2016, 8:13 AM
TTO added a subscriber: TTO.

wikEdDiff is maintained by English Wikipedia community members, and issues with it are unfortunately not handled on Phabricator. See matmarex's comment for what you should do to get this issue fixed.