Copying and pasting text and new refs from wikitext results in some old refs being inserted instead
Closed, ResolvedPublic0 Story Points

Description

Action taken:
I copied this text from the German Wikipedia, and pasted it into VisualEditor:

England gelang zwar sechs Minuten später durch einen von [[Allan Clarke (Fußballspieler)|Allan Clarke]] verwandelten Elfmeter der Ausgleich, mehr ließen die Polen, insbesondere ihr Torhüter [[Jan Tomaszewski]] - der kurz zuvor von [[Brian Clough]] als Clown tituliert wurde - nicht zu.<ref>[http://eu-football.info/_match.php?id=12071 eu-football.info: „Football MATCH: 17. Oktober 1973 England v Poland“]</ref> „It's all over“ wurde dies vom Kommentator des Spiels kommentiert.<ref>[https://www.youtube.com/watch?v=Vi9vZCo215w England 1-1 Poland (1973) WCQ ]</ref>

(Actually, I copied more than that and then deleted half of it.)

Expected result: The two sentences and their refs appear on the page.

Actual result: Two refs from elsewhere on the page were duplicated (not re-used) instead of the new (correct) ones being added. The new ones simply vanished. Also, an extra ref block was added (T127664: Copying and pasting wikitext with refs results in the addition of a <references /> block), but I removed that before saving the page. See https://en.wikipedia.org/w/index.php?title=User:Whatamidoing_(WMF)/sandbox&diff=706161252&oldid=705314879

T127664 is reproducible; however, I was not able to reproduce the wrong-ref problem (only one attempt).

Restricted Application added a project: VisualEditor. · View Herald TranscriptFeb 21 2016, 9:09 PM
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald Transcript
Jdforrester-WMF triaged this task as High priority.Apr 19 2016, 7:23 PM
Jdforrester-WMF set the point value for this task to 8.
Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptApr 19 2016, 7:23 PM
Deskana closed this task as Resolved.Jul 26 2017, 10:15 AM
Deskana changed the point value for this task from 8 to 0.
Deskana claimed this task.
Deskana added a subscriber: Deskana.

This seems to have been fixed at some point, as the copy-paste now works as expected.

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptJul 26 2017, 10:15 AM