Change in transaction field order breaks Phlogiston import
Closed, ResolvedPublic

Description

Steps to Reproduce
Run Phlogiston (circa 2016-02-21 code) against post-Feb-2016-upgrade Phabricator dump.

Expected Result
VE parent milestone raw data looks like

1660	Make ULS input methods work in content editable divs of VisualEditor	VisualEditor	
4484	Make ULS input methods work in content editable divs of VisualEditor	VisualEditor	Backlog
446	Make ULS input methods work in content editable divs of VisualEditor	VisualEditor	TR3: Language support
7	Make ULS input methods work in content editable divs of VisualEditor	VisualEditor 2014/15 Q4 blockers	
69	Make ULS input methods work in content editable divs of VisualEditor	VisualEditor 2014/15 Q4 blockers	Backlog
13	Make ULS input methods work in content editable divs of VisualEditor Make VisualEditor good enough to use with all common IMEs for Korean	VisualEditor	Backlog
8	Make ULS input methods work in content editable divs of VisualEditor Make VisualEditor good enough to use with all common IMEs for Korean	VisualEditor	TR8: ????
11	Make ULS input methods work in content editable divs of VisualEditor Make VisualEditor good enough to use with all common IMEs for Korean	VisualEditor 2014/15 Q3

Charts and reports are complete.

Actual Result
VE parent milestone raw data looks like

1672	1371201120	VisualEditor	
4484	1371201120	VisualEditor	Backlog
485	1371201120	VisualEditor	TR3: Language support
7	1371201120	VisualEditor 2014/15 Q4 blockers	
69	1371201120	VisualEditor 2014/15 Q4 blockers	Backlog
13	1371201120 1440751877	VisualEditor	Backlog

Charts and reports are missing lots of data.

Phlogiston at several points uses Phab dump data based on column number within the JSON data structure. This has probably changed.

Restricted Application added a subscriber: revi. · View Herald TranscriptFeb 22 2016, 9:34 PM
JAufrecht updated the task description. (Show Details)Feb 22 2016, 9:35 PM
JAufrecht closed this task as Resolved.Mar 2 2016, 12:10 AM

fix added last week; several automatic runs in a row seem okay

JAufrecht renamed this task from Change in field order breaks Phlogiston import to Change in transaction field order breaks Phlogiston import.Mar 2 2016, 12:10 AM
Restricted Application added subscribers: TerraCodes, Urbanecm. · View Herald TranscriptApr 19 2016, 10:49 PM