Page MenuHomePhabricator

Use PNG (not SVG) for notification emails so they work in Gmail
Closed, ResolvedPublic

Event Timeline

Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptFeb 23 2016, 6:21 AM
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptFeb 23 2016, 8:41 AM
Mattflaschen-WMF renamed this task from Broken icon in message email notification to Use PNG for notification emails so they work in Gmail.Feb 25 2016, 5:20 AM
Mattflaschen-WMF updated the task description. (Show Details)
Mattflaschen-WMF renamed this task from Use PNG for notification emails so they work in Gmail to Use PNG (not SVG) for notification emails so they work in Gmail.

I've heard back from Google support, and they've confirmed there are currently no plans to support SVG images in the proxy. They said they account for only 1 in 100,000 email images.

... Meanwhile, everyone is changing SVG images to other formats precisely because they don't support it... Good job Google.

I wonder if you could (ab)use ResourceLoaderImageModule, and the load.php?image=…&format=rasterized URLs it generates, for a fairly easy workaround?

Change 304299 had a related patch set uploaded (by Mooeypoo):
Add a rasterized email icons to Echo modules for email

https://gerrit.wikimedia.org/r/304299

Change 304299 merged by jenkins-bot:
Add a rasterized email icons to Echo modules for email

https://gerrit.wikimedia.org/r/304299

Checked in betalabs

  1. the image urls in gmail is changed e.g. before the fix: https://ci5.googleusercontent.com/proxy/Oud_2pyP[..]#https://en.wikipedia.beta.wmflabs.org/w/extensions/Flow/modules/notification/icon/flow-new-topic.svg

after the fix
https://ci6.googleusercontent.com/proxy/qerRsnzR[...]#https://en.wikipedia.beta.wmflabs.org/w/load.php?modules=ext.echo.emailicons&image=flow-new-topic&lang=en&format=rasterized

  1. the screenshots below show email notifications with icons displayed for the following events:
    • Flow pages notifications (e.g. a new topic was created)

  • Thanks

  • Mention

  • User rights change

  • Educational program enrollment

  • Revert edits

  • Page link

  • Page review

jmatazzoni closed this task as Resolved.Aug 19 2016, 12:00 AM