Page MenuHomePhabricator

Projects should have an "Open Tasks" view by default
Closed, ResolvedPublic

Description

I used to be able to click a tag, click "open tasks" on the sidebar and see a list of open reports for that project. (T89865 made that slower but still feasible, at least for people with good enough CPUs and networking.) Nowadays, I have no idea how to reach the same result in less than 10 clicks or so (e.g. manually building a query from Maniphest Advanced search).

Upstream task (with potential Phabricator extension code): T10308 Please undo some changes

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes
Restricted Application added subscribers: StudiesWorld, scfc, Aklapper. · View Herald TranscriptFeb 23 2016, 11:22 PM

Going to the workboard is the default for most projects nowadays I guess, list all tasks, and requires one click.

The workboard is not a real list of tasks, is not a search, is hardly visible on most screens, and is not desired anyway (T89865).

This task does not block T89865. No matter if the workboard or the project description page or anything else available is displayed, you still won't have a link to "list of tasks in this project" by default. Hence removing that dependency. Please do not re-add. If you think it should be re-added, please instead explain why you think it is a dependency. Thanks.

Nemo_bis added a comment.EditedMay 17 2016, 7:09 AM

This continues to annoy me a lot every day. It really does make me wonder whether the Phabricator developers are in a crusade against humanity's joy. (Most of the time I just give up, so I end up not knowing anything about the project's tasks. Perhaps it's some kind of patronising way to discourage people from finding more tasks than those they've been notified about? Are the developers worried that one might get sad by interacting too much with a project, and hoping that everyone will be happier by living in their little world?)

Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptMay 17 2016, 7:09 AM

@Nemo_bis: Please stick to Phabricator etiquette when commenting. If you do not wish to contribute in a positive way to this discussion, I suggest you spend your time on other topics. Thanks.

scfc added a comment.May 17 2016, 5:42 PM

@Aklapper: You have made it perfectly clear on several occasions that you have no empathy for @Nemo_bis's pain. To expect him to "contribute in a positive way" from that position is inhumane (and not even part of the Phabricator Etiquette). Please develop the necessary skills perhaps by your employer's training or leave @Nemo_bis alone.

matmarex added a subscriber: matmarex.
matmarex added a comment.EditedMay 17 2016, 5:49 PM

Workboards should be disabled in most projects, and even when they're enabled they're not exactly user-friendly when you just want the list of tasks. I agree that this is horrible and wastes a few minutes of my time every day.

@Nemo_bis The only solution ridiculous workaround is to "Manage" the project, "Edit Menu", then add a custom link pointing to the list of open tasks (which you have to create with the advanced search). You have to do this for every project you care about. I did it for UploadWizard some time ago.

off-topic

In reply to T127903#2301883 by @scfc: To clarify my intention to add comment T127903#2301226: I referred to the second sentence in T127903#2300059 but I did not make that explicit. I'm sorry for that.

Danny_B closed this task as Resolved.Aug 14 2016, 3:48 PM
Danny_B claimed this task.
Danny_B added a subscriber: Danny_B.

Solution described in T127903#2301904

Danny_B removed Danny_B as the assignee of this task.Aug 14 2016, 3:49 PM
Nemo_bis reopened this task as Open.Aug 14 2016, 6:07 PM

That's not a "resolved", at best it's a "declined".

Danny_B triaged this task as Lowest priority.EditedAug 14 2016, 7:24 PM

@Nemo_bis Please provide reasons for reopening the task which has been closed due to the existence of (simple) solution. Thank you.

I'm sorry, that is not a "solution", that's a ridiculous workaround.

matmarex raised the priority of this task from Lowest to Needs Triage.Aug 14 2016, 8:58 PM

I'm sorry, that is not a "solution", that's a ridiculous workaround.

So what exactly is a problem? Content-less sentences like this won't help anything. Please describe your needs, so those who are willing to help, can have an idea what they should actually focus on.

I want, for any random project, let's say… [rolls dice] MediaWiki-extensions-Babel, to be able to view the list of open tasks associated with this project no further than one click away from clicking on a project name such as the one above.

Right now, this requires (and this is a manual one-time action for each project) either converting the tag to a workboard, or adding a custom link in the sidebar like I described earlier.

Great, so we can move further now. Thank you, @matmarex.

OK. So let me verify if I understand you correctly: You want when clicking on MediaWiki-extensions-Babel to get to something like https://phabricator.wikimedia.org/maniphest/query/L_oS34qZWv3R/#R (± some filtering/grouping/ordering details)?

Also, please explain/elaborate what "converting the tag to a workboard" means. I would like to prevent misunderstandings. Thank you.

Yes. It's also fine for me if such a list is accessible directly (one click) from the page displayed on MediaWiki-extensions-Babel.

(I'd prefer it to be sorted by creation date rather than priority, but that's a minor detail I can live without. I think the fact that priority is pretty useless is specific to our installation and workflows.)

I can't really elaborate on workboards, I'm not sure how that even works. I'm not a big fan of them.

Thank you.

Yes. It's also fine for me if such a list is accessible directly (one click) from the page displayed on MediaWiki-extensions-Babel.

So then the issue is solved then by your own words:

The only solution is to "Manage" the project, "Edit Menu", then add a custom link pointing to the list of open tasks (which you have to create with the advanced search).

Hence why I closed the task.


I can't really elaborate on workboards, I'm not sure how that even works. I'm not a big fan of them.

I asked you to elaborate on what you mean by your own sentence "converting the tag to a workboard", because I don't have any idea what to imagine under that, how such conversion should work or look like... Hard to come up with possibilities and solutions if it is not clear what exactly you desire. :-/

Yes. It's also fine for me if such a list is accessible directly (one click) from the page displayed on MediaWiki-extensions-Babel.

So then the issue is solved then by your own words:

The only solution is to "Manage" the project, "Edit Menu", then add a custom link pointing to the list of open tasks (which you have to create with the advanced search).

Hence why I closed the task.

It's not solved because it requires manual action for every. single. project. That's not a fix.

Danny_B triaged this task as Lowest priority.Aug 15 2016, 11:31 AM

It's not solved because it requires manual action for every. single. project. That's not a fix.

Nope. Only for those, where someone requires that, as it is optional add-on to the current behavior. Obviously the most majority of users doesn't care.

Anyway, if someone doesn't like it, then s/he should file an upstream task about it (and link it here). Sure we can discuss it here round and round into eternity, but it won't be productive at all.

I've found an upstream task for this one, and they provided a phabricator extension to add that link for all projects (if I understood correctly): https://secure.phabricator.com/T10308#158036

Maybe we can install it here?

Nice job, @Ciencia_Al_Poder, thank you!

Aklapper renamed this task from Innumerable clicks required from tag to open task lists to When a project has no workboards enabled, many clicks are required to open the task list of that project.Sep 9 2016, 12:58 PM
Aklapper raised the priority of this task from Lowest to Low.
Aklapper updated the task description. (Show Details)
mmodell added a subscriber: mmodell.Sep 9 2016, 4:36 PM

@Ciencia_Al_Poder: I've added the extension. Unfortunately it doesn't add the menu item by default so we still have to go to manage->configure menu and add the link to each project.

There is probably some way to mass-add it but I'm not sure how difficult that would be.

I've added the extension. Unfortunately it doesn't add the menu item by default so we still have to go to manage->configure menu and add the link to each project.

Extension does not seem to work correctly.
I added "Open Tasks" to the menu of a project but that link also lists resolved tasks. Query form on top shows no criteria (like "Any open") in the "Statuses" field.

This project is selected for the Developer-Wishlist voting round and will be added to a MediaWiki page very soon. To the subscribers, or proposer of this task: please help modify the task description: add a brief summary (10-12 lines) of the problem that this proposal raises, topics discussed in the comments, and a proposed solution (if there is any yet). Remember to add a header with a title "Description," to your content. Please do so before February 5th, 12:00 pm UTC.

Krinkle renamed this task from When a project has no workboards enabled, many clicks are required to open the task list of that project to Projects should have an "Open Tasks" view by default.Feb 6 2017, 7:55 PM
Krinkle updated the task description. (Show Details)

A recent Phabricator upgrade changed the "Manage project" to have an easy way to add a link to "Open Tasks". While this is a step in the right direction, it seems flawed in two ways:

  • It defaults to grouping and sorting by priority, which is not very useful (should probably default to no grouping and sorting by creation date or last updated or some such).
  • The link destination can't be changed (its edit page is blank).

A recent Phabricator upgrade changed the "Manage project" to have an easy way to add a link to "Open Tasks".

Just for clarity: this is a downstream extension, not part of the upstream, and lives here:

https://phabricator.wikimedia.org/source/phab-extensions/browse/wmf%252Fstable/src/panel/ProjectOpenTasksProfileMenuItem.php

@epriestley Thanks. That's quite straight forward, I'll see what I can do with it. Meanwhile, I've proposed another one for T163848 at D627.

I think this has been implemented? I see such a link on most projects now, but I'm not sure if all have it.

mmodell closed this task as Resolved.Aug 8 2018, 5:56 PM
mmodell claimed this task.
Krinkle reopened this task as Open.EditedAug 8 2018, 5:59 PM

Re-opening as WrappedString was recently created and did not have it by default. I've spot-checked a dozen or so other recently created projects and found the same there.

The reason these projects, and many other ones, now do have that link is because others and myself keep manually adding it everywhere. This task is about not needing to do that.

Framawiki removed mmodell as the assignee of this task.Aug 8 2018, 6:02 PM

This will be deployed tonight at approximately midnight UTC.

Nemo_bis added a comment.EditedAug 8 2018, 7:07 PM

Thanks! :-) Looks like a clean solution. (Should the assignee be set to @mmodell again?)