Page MenuHomePhabricator

Report duplicate key fetches
Closed, ResolvedPublic

Description

Include per-request BagOStuff key leaderboard table in ?forceprofile. This would be useful for detecting duplicate key fetches, which seem to keep popping up in places.

Alternately (additionally?) make BagOStuff implementations keep an array buffer of all keys requested during the current request, and then on post-send go through that array to look for dupes and report them via a warning or a log message.

Related Objects

StatusAssignedTask
DeclinedNone
Resolvedaaron

Event Timeline

aaron created this task.Feb 25 2016, 8:31 PM
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptFeb 25 2016, 8:31 PM
aaron updated the task description. (Show Details)Feb 25 2016, 8:32 PM
ori triaged this task as Normal priority.Feb 29 2016, 7:47 PM
ori moved this task from Inbox to Backlog: Small & Maintenance on the Performance-Team board.
ori added a subscriber: ori.Feb 29 2016, 9:26 PM

We could also catch dupes by having BagOStuff implementations keep track of keys that have been retrieved during the current request, and emit some log message on duplicate fetches.

ori renamed this task from Include per-request BagOStuff key leaderboard table in ?forceprofile to Report duplicate key fetches.Mar 2 2016, 1:31 AM
ori updated the task description. (Show Details)

Change 274333 had a related patch set uploaded (by BryanDavis):
BagOStuff: Optionally log duplicate key lookups

https://gerrit.wikimedia.org/r/274333

aaron removed aaron as the assignee of this task.Apr 21 2016, 9:05 PM

Change 274333 merged by jenkins-bot:
BagOStuff: Optionally log duplicate key lookups

https://gerrit.wikimedia.org/r/274333

hashar added a subscriber: hashar.Apr 26 2016, 7:17 PM

That causes a bunch of log, but I guess we can not easily reproduce the dupes via tests.

aaron closed this task as Resolved.Jun 6 2016, 11:16 AM
aaron claimed this task.