Page MenuHomePhabricator

Change Password on Beta failed
Closed, ResolvedPublic

Description

I have forgotten my old password on http://de.wikipedia.beta.wmflabs.org/ so I got a one-time-password per email:

I got this error:

[067178d6] /wiki/Spezial:Passwort_%C3%A4ndern MWException from line 3782 of /srv/mediawiki/php-master/includes/user/User.php: 
CAS update failed on user_touched for user ID '228' (read from slave); the version of the user to be saved is older than the current version.

Backtrace:
#0 /srv/mediawiki/php-master/includes/specials/SpecialChangePassword.php(303): User->saveSettings()
#1 /srv/mediawiki/php-master/includes/specials/SpecialChangePassword.php(204): SpecialChangePassword->attemptReset(string, string, string)
#2 /srv/mediawiki/php-master/includes/htmlform/HTMLForm.php(607): SpecialChangePassword->onSubmit(array)
#3 /srv/mediawiki/php-master/includes/htmlform/HTMLForm.php(504): HTMLForm->trySubmit()
#4 /srv/mediawiki/php-master/includes/htmlform/HTMLForm.php(519): HTMLForm->tryAuthorizedSubmit()
#5 /srv/mediawiki/php-master/includes/specialpage/FormSpecialPage.php(154): HTMLForm->show()
#6 /srv/mediawiki/php-master/includes/specials/SpecialChangePassword.php(55): FormSpecialPage->execute(NULL)
#7 /srv/mediawiki/php-master/includes/specialpage/SpecialPage.php(407): SpecialChangePassword->execute(NULL)
#8 /srv/mediawiki/php-master/includes/specialpage/SpecialPageFactory.php(565): SpecialPage->run(NULL)
#9 /srv/mediawiki/php-master/includes/MediaWiki.php(282): SpecialPageFactory::executePath(Title, RequestContext)
#10 /srv/mediawiki/php-master/includes/MediaWiki.php(738): MediaWiki->performRequest()
#11 /srv/mediawiki/php-master/includes/MediaWiki.php(519): MediaWiki->main()
#12 /srv/mediawiki/php-master/index.php(43): MediaWiki->run()
#13 /srv/mediawiki/w/index.php(3): include(string)
#14 {main}

Event Timeline

Boshomi created this task.Feb 27 2016, 8:03 AM
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptFeb 27 2016, 8:03 AM

I was getting the same error on Chinese wikipedia when I tried to change my password.

Luke081515 triaged this task as Unbreak Now! priority.Feb 27 2016, 11:33 AM
Luke081515 updated the task description. (Show Details)Feb 27 2016, 12:35 PM
Luke081515 updated the task description. (Show Details)
Anomie added a subscriber: ori.EditedFeb 27 2016, 3:34 PM

I'm going to guess this is due to rMW7d67b4d91953: Prevent duplicate memcached lookups for user record not updating the in-process cache on save, so something later during the request that loads a User object and tries to save it gets the old mTouched from the old cache.

Update: I could reproduce on mw1017. Then I removed that patch and could no longer reproduce.

Restricted Application added a subscriber: Luke081515. · View Herald TranscriptFeb 27 2016, 3:46 PM
Krenair added a subscriber: Krenair.EditedFeb 27 2016, 9:54 PM

It was reverted: https://gerrit.wikimedia.org/r/#/c/273592/ (but not on master which beta runs)

Luke081515 closed this task as Resolved.Apr 7 2016, 2:02 PM

Should be resolved now, I can't reproduce it now.