Page MenuHomePhabricator

[Bug] Add qualifier does not disappear when a new statement is saved
Closed, ResolvedPublic

Description

In Firefox, you save a new statement, you can still click on "add qualifier" which is normally clickable only when you edit a whole statement.

Event Timeline

Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptFeb 28 2016, 11:47 AM

I can confirm this. You can even add the qualifier, but there's no option to save it. No save button and pressing enter doesn't do anything. When you click edit on the statement you get the possibility to save the qualifier without the need of re-adding the qualifier, the information is still present. But when you can add a qualifier, you expect to be able to save it as well.

Lydia_Pintscher renamed this task from Add qualifier does not disappear when a new statement is saved to [Bug] Add qualifier does not disappear when a new statement is saved.Mar 3 2016, 8:04 AM
Lydia_Pintscher triaged this task as Normal priority.
Lydia_Pintscher raised the priority of this task from Normal to High.Mar 16 2016, 9:42 AM

Getting more complaints about this. We need to fix it.

This only happens when number of qualifiers is 0.
The reason is that 'listviewcreate' event is triggered after stop editing.

Change 277782 had a related patch set uploaded (by Jonas Kress (WMDE)):
Fix: Add qualifier does not disappear when a new statement is saved

https://gerrit.wikimedia.org/r/277782

Change 277782 merged by jenkins-bot:
Fix: Add qualifier does not disappear when a new statement is saved

https://gerrit.wikimedia.org/r/277782

Lydia_Pintscher closed this task as Resolved.Mar 21 2016, 10:27 AM
Lydia_Pintscher claimed this task.

Change 278963 had a related patch set uploaded (by Hoo man):
Fix: Add qualifier does not disappear when a new statement is saved

https://gerrit.wikimedia.org/r/278963

Change 278963 merged by jenkins-bot:
Fix: Add qualifier does not disappear when a new statement is saved

https://gerrit.wikimedia.org/r/278963