Page MenuHomePhabricator

Unexpected selection of entire para content while using "Page title" section heading feature from VE menubar
Closed, DeclinedPublic

Description

Please do refer to this edit diff on marathi language wikipedia

Upon studying and testing the said edit diff and user communication, undersigned realised that the user not so wellversed with wiki change of (move) article name procedure, enabled VE edit made a minor spell change in Second word in first line. The spell change happened ok now he wanted to change/move page title to new changed spelling in the paragraph, He selected only first two words सोमदेव सुरि and then selected "Page title" from VE drop down menu for top section heading ( i.e. = top section heading refered as page title=) and saved the page where in expected behaviour of the VE software should have been only creating section for first two selected words (i.e. =सोमदेव सुरि=) only should become section heading. But instead entire paragrah gets selected as a section heading first = came before first word of the paragraph and second = went all the way after end of the paragraph. And prima facia this seems to be a VE bug. I tested it on a separate sandbox page on mr wikipedia and I could reproduce this bug. (Browser used by me was Fire fox auto updated latest version and Windows 10 auto updated version)

Thanks and warm regards

Event Timeline

Mahitgar created this task.Feb 28 2016, 5:00 PM
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptFeb 28 2016, 5:00 PM
Mahitgar updated the task description. (Show Details)Feb 28 2016, 5:32 PM
Jdforrester-WMF closed this task as Declined.Feb 28 2016, 11:32 PM
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

All of the formatting commands apply to all of the paragraph(s) in which the cursor/selection currently resides, which is intentionally the same behaviour as in Google Docs, Microsoft Office and other rich text editors.

It's very important that the interface for the visual editor works in a way that is the least surprising for the majority of our users, and adopting interface mechanisms that are the most consistent with similar software out in the wider world is one of the main ways in which we seek to do this.

That said, I do worry that "Page title" though accurate doesn't necessarily convey to the user exactly what will happen when they click on it, even in context of a series of other levels of heading and other types of paragraph-level formatting options. (The HTML term, "Heading level 1", is probably worse, though; we very much don't want to encourage people to use it in general practice, which that would suggest.) If you have suggestions for how we could re-phrase the label to a similarly brief comment that gives a better understanding of this, I'd be grateful.