'Mark as read' in dotdotdot menu does nothing
Closed, ResolvedPublic

Description

  1. Have some Notifications - open the Notification panel.
  2. Click on the dot menu - 'Mark as read' will be displayed.
  3. Click on the 'Mark as read' option - nothing happens.

'Mark as read' fails for cross wiki notifications too.

Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptMar 1 2016, 1:50 AM
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald Transcript
Catrope triaged this task as Unbreak Now! priority.Mar 1 2016, 2:13 AM
Catrope added a subscriber: Catrope.

WTF?! Confirmed locally, clicking "Mark as read" does nothing at all.

And, since on the topic of 'Mark as read'

    • Click on the dot menu
  • with the dot menu options open - scroll up and then down. You'll see the menu get distorted:


with cross-wiki dot menu

Change 274049 had a related patch set uploaded (by Catrope):
Follow-up 07c5850b: unbreak "mark as read" menu item

https://gerrit.wikimedia.org/r/274049

Catrope renamed this task from [betalabs] 'Mark as read' in dot menu does not work again to 'Mark as read' in dotdotdot menu does nothing.Mar 1 2016, 2:41 AM

And, since on the topic of 'Mark as read'

    • Click on the dot menu
  • with the dot menu options open - scroll up and then down. You'll see the menu get distorted:

I've split this off to T128436: dotdotdot menu layout breaks on scroll / window resize

Change 274049 merged by jenkins-bot:
Follow-up 07c5850b: unbreak "mark as read" menu item

https://gerrit.wikimedia.org/r/274049

Checked in betalabs for local wiki dotdotdot option and for cross-wiki - all options in the menu work.

jmatazzoni closed this task as Resolved.Mar 3 2016, 7:05 PM