Page MenuHomePhabricator

For users that ignore instructions, provide a second "this is how to switch editors" pop-up inside VisualEditor
Closed, DeclinedPublic

Description

When a new user first edits a page, a popup offers the option of switching to wikitext or keeping with VE. If the user selects VE, there is no obvious way to get back the popup and no indication of how to switch to wikitext otherwise. If the user selects wikitext, there is a guider pointing out the back to VE button. If the user uses that button, the button taking them in the opposite direction is not highlighted.

The VE -> wikitext switch should have an identical guider (with user confirmation needed to prevent it from appearing in the future) to the wikitext -> VE switch.

Event Timeline

Tgr created this task.Mar 3 2016, 8:02 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 3 2016, 8:02 PM
Elitre renamed this task from VisusalEditor: no visual indication of how to change to wikitext editing to VisualEditor: no visual indication of how to change to wikitext editing.Mar 3 2016, 10:05 PM
Elitre added a subscriber: Elitre.
Zppix added a subscriber: Zppix.Mar 3 2016, 10:26 PM

There's a pencil I believe near the top right corner of the VE window. And on source editing its also there.

Thanks Zppix. The problem is not Tgr's one though.
FWIW the switch mechanism is also explained on both the announcements at the wikis and the SET overview at mediawiki.org.
We just heard of people who didn't notice those buttons on the toolbar (or who dismissed too soon the popup for one of them).

Jdforrester-WMF renamed this task from VisualEditor: no visual indication of how to change to wikitext editing to For users that ignore instructions, provide a second "this is how to switch editors" pop-up inside VisualEditor.Mar 7 2016, 8:19 PM
Jdforrester-WMF closed this task as Declined.Mar 7 2016, 8:21 PM
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

I've re-written the title to match reality (there is a visual notification; @Tgr's report is talking about serving users who ignored it).

I think this would be a poor outcome for the majority of our users who would now have a fourth or even fifth pop-up on first-run (welcome, how-link-works, how-cite-works, any page alerts, and this). As it is we should have fewer. Adding more pop-ups mean people read them less.

This comment was removed by Elitre.