Page MenuHomePhabricator

TranslationNotifications emails should contain valid sender
Closed, ResolvedPublic

Description

Current behaviour

Emails sent by the translation notifications extension do not contain any content on the sender field:

To: MarcoAurelio <[REDACTED]>
Subject: =?UTF-8?Q?Traduce=20la=20p=C3=A1gina=20CKoerner=20(WMF)/Work/Completion=20Suggester=20inital=20rollout?=
From: 
Reply-To: 
Date: Fri, 04 Mar 2016 19:55:17 +0000
Message-ID: <metawiki.56d9e8259b55e2.57792884@meta.wikimedia.org>
X-Mailer: MediaWiki mailer
List-Unsubscribe: <https://meta.wikimedia.org/wiki/Special:Preferences>
MIME-Version: 1.0
Content-type: text/plain; charset=UTF-8
Content-transfer-encoding: 8bit

Expected behaviour

A name and an email address (such as notifications-noreply@wikimedia.org or other best suited) should be present, so that people and systems see where the mail is comming from.

Event Timeline

I think this is high priority as long as messages without valid sender will likely end blocked by the email services or on the spam folders of the translators, making the notification useless. Please rise or lower the priority of this as you think it's most appropriate in case you disagree with me.

Maybe https://gerrit.wikimedia.org/r/#/c/207996/ has something to do with this? On the code $wgNoReplyAddress is used several times. Either we add one in the code, or use defaults from wmf-config/InitialiseSettings.php (LL. 15292-15296). That might solve the absence of an email address from where the notification is comming from, but still the name of the translation administrator sending the mail should also be avalaible.

I have recently experienced this issue along with another explained in the ticket link below.

https://phabricator.wikimedia.org/T127751#2135198

This occurred for me while sending out the Wikimedia Highlights for February 2016. There also seems to be no log entry for this sent message.

https://meta.wikimedia.org/w/index.php?title=Special%3ALog&type=notifytranslators&user=&page=&year=&month=-1&tagfilter=

I continue to receive translation notifications emails in which the sender or its email address fields are empty, and the patch you link is already merged. Best regards.

From last mail:

To: MarcoAurelio <[REDACTED]>
Subject: =?UTF-8?Q?Traduce=20la=20p=C3=A1gina=20Tech/Server=20switch=202016?=
From: 
Reply-To: 
Date: Wed, 23 Mar 2016 18:34:06 +0000
Message-ID: <metawiki.56f2e19eb877f5.55287113@meta.wikimedia.org>
X-Mailer: MediaWiki mailer
List-Unsubscribe: <https://meta.wikimedia.org/wiki/Special:Preferences>
MIME-Version: 1.0
Content-type: text/plain; charset=UTF-8
Content-transfer-encoding: 8bit

I continue to receive translation notifications emails in which the sender or its email address fields are empty, and the patch you link is already merged. Best regards.

Merged != Deployed != Live on your target wiki

It's in wmf/1.27.0-wmf.18, which looks to have been on meta maybe 24 hours now

But that's after your last email, I think

19:05 logmsgbot: thcipriani@tin rebuilt wikiversions.php and synchronized wikiversions files: group1 wikis to 1.27.0-wmf.18

I've just received a translation notification email from commons. The mail shows the username of the TranslationAdministrator sending the notification, with email address wiki-at-wikimedia. Should be fine now. Will let others close for doublechecking. Best regards.

Per my comment above, I think this task is resolved. If you disagree, please reopen the task again.