Page MenuHomePhabricator

enable cat-a-lot gadget on wikimediafoundation.org
Closed, ResolvedPublic

Description

The Cat-a-lot gadget (enabled on Commons) is very useful for cleaning up inconsistently categorized pages. It would be tremendously useful on wikimediafoundation.org.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 5 2016, 9:35 PM
Krenair closed this task as Invalid.Mar 5 2016, 10:00 PM
Krenair added a subscriber: Krenair.

Gadget importing/creation/enabling is not handled centrally by the developers, admins of each wiki deal with it. As such, this request needs to go to the admins of that wiki, and I do not believe they track tasks in Phabricator.

Many thanks, MZMcBride!

@MZMcBride, sorry if this is more complicated than it first seemed. In order to be useful on WMF Wiki, this will need to permit categorization of pages. That's an option in the Cat-A-Lot preferences, which is not checked by default:

"Allow categorising pages (including categories) that are not files"

However, it looks like the Cat-A-Lot preferences may require some additional Javascript, or something..? It invokes an unusual dialogue when used on Commons.

Any chance you can chase that down? I hope this isn't asking too much -- any help appreciated.

Thanks for taking a shot at that, @MZMcBride . Unfortunately I'm still not able to see the preferences screen. @Rillke , do you know anything about how Cat-a-lot uses Javascript, and how we could get it working on another wiki?

You should upload a screenshot (or many screenshots!) and describe clearer steps to reproduce whatever issue it is you're having. I've never used this gadget before. I know almost nothing about it. It should be mostly working on wikimediafoundation.org: I enabled it on my account briefly to make sure it popped up in the corner of a category description page.

MZMcBride reopened this task as Open.Mar 8 2016, 12:07 AM

@MZMcBride , first -- I think my own issue is now resolved (I copied text from my common.js file on Commons to WMF Wiki) -- but this is probably worth tracking down in case somebody else wants to use the gadget. In other words, I think I was able to manually change my preferences by putting the file there myself -- but the interface to the Preferences screen still doesn't work on WMF Wiki.

I've attached a screen shot of the Preferences screen. If you look in the lower right corner of the screen, you'll see the Cat-A-Lot menu; the bottom item in the menu is "Preferences." When it's working properly (the screenshot is from Commons), it brings up the window in the center of the screen.

But when I click "Preferences" there on WMF Wiki, nothing at all happens.

Rillke added a comment.EditedMar 8 2016, 1:45 AM

This is because mw.loader.using( [ 'ext.gadget.SettingsManager', 'ext.gadget.SettingsUI', 'jquery.ui.progressbar' ], function() { ... } );

In other words you need SettingsManager, SettingsUI and as a nested dependency libJQuery.

In other words you need SettingsManager, SettingsUI and as a nested dependency libJQuery.

Good grief. I pulled in SettingsManager and SettingsUI. I thought that jQuery UI was either still in MediaWiki core or that this gadget would be using whatever is used by core. But... that wasn't right! I hadn't realized that gadgets had gotten as bad as templates to export/duplicate. :-(

Rillke added a comment.Mar 8 2016, 2:03 AM

I hadn't realized that gadgets had gotten as bad as templates to export/duplicate. :-(

We really need a central gadget repository. And the name libJQuery is pretty confusing, yes... Cat-a-lot has been written primarily with files in mind, now it is apparently exported everywhere to categorize pages... usability of this gadget is horrific, still it is one of the most popular ones at Commons.

It works -- thank you all for your efforts! It's tremendously useful for wiki-gnoming, and will permit me to do a bunch of long-deferred organizing on wmf wiki. If what you just did is easily transferrable to Meta Wiki, I could use it there for some projects too...but I don't want to wear out my welcome on requests :)

I do want to strenuously protest the "usability is horrific" statement, @MZMcBride. This gadget permits actions that as far as I know are not possible with any other comparable tool. The usability is *unusual*, yes -- but just a few minutes of playing around was enough for me to figure it out, and I've been able to do a great deal of work on Commons since that simply wasn't possible beforehand. Please consider the constraints that an author of a gadget like this works under -- I think "horrific" is really undeserved, and I'm very grateful for this and many of the sophisticated Javascript-based tools available on Commons.

It works -- thank you all for your efforts! It's tremendously useful for wiki-gnoming, and will permit me to do a bunch of long-deferred organizing on wmf wiki.

Awesome! Is this task now resolved, then? If so, could you please mark it as such?

If what you just did is easily transferrable to Meta Wiki, I could use it there for some projects too...but I don't want to wear out my welcome on requests :)

You can file a new Phabricator Maniphest task about adding Cat-a-lot to Meta-Wiki or you can hit me up on my Meta-Wiki talk page. Now that I've installed Cat-a-lot on wikimediafoundation.org, installing it on Meta-Wiki should be simpler.

I do want to strenuously protest the "usability is horrific" statement, @MZMcBride.

That was @Rillke, not me. ;-) I still don't really know anything about this gadget. I can say that MediaWiki's category infrastructure is pretty sad and that in an ideal world, it would not require Commoners writing a lot of JavaScript to make category management less painful. Like you, I also appreciate the work that @DieBuche and others have done, but I think even these gadget authors would agree that we need better tools in MediaWiki.

Please consider the constraints that an author of a gadget like this works under -- I think "horrific" is really undeserved, and I'm very grateful for this and many of the sophisticated Javascript-based tools available on Commons.

Sure. I've been trying to temper my language when discussing code that others wrote. That said, we really do need to come up with a better system for adding, removing, and modifying categories. This is not to say that JavaScript can't or won't be part of some solutions, but MediaWiki itself needs to be improved. The current architecture simply isn't scalable, sustainable, or reasonable. It should not require users pulling in a half-dozen or more JavaScript and CSS pages just to make it easier to do basic wiki maintenance.

Peteforsyth closed this task as Resolved.Mar 8 2016, 4:46 PM
Peteforsyth claimed this task.

Awesome! Is this task now resolved, then? If so, could you please mark it as such?

Now done. I had been planning to bake a cake and find a party hat first ;)

You can file a new Phabricator Maniphest task about adding Cat-a-lot to Meta-Wiki or you can hit me up on my Meta-Wiki talk page. Now that I've installed Cat-a-lot on wikimediafoundation.org, installing it on Meta-Wiki should be simpler.

Will do. Thanks!

I do want to strenuously protest the "usability is horrific" statement, @MZMcBride.

That was @Rillke, not me. ;-)

Groan...I read this entirely wrong, I thought that entire comment was you. Which didn't make a lot of sense, and I should have double-checked before responding. My apologies!

I still don't really know anything about this gadget. I can say that MediaWiki's category infrastructure is pretty sad and that in an ideal world, it would not require Commoners writing a lot of JavaScript to make category management less painful. Like you, I also appreciate the work that @DieBuche and others have done, but I think even these gadget authors would agree that we need better tools in MediaWiki.

Please consider the constraints that an author of a gadget like this works under -- I think "horrific" is really undeserved, and I'm very grateful for this and many of the sophisticated Javascript-based tools available on Commons.

Sure. I've been trying to temper my language when discussing code that others wrote. That said, we really do need to come up with a better system for adding, removing, and modifying categories. This is not to say that JavaScript can't or won't be part of some solutions, but MediaWiki itself needs to be improved. The current architecture simply isn't scalable, sustainable, or reasonable. It should not require users pulling in a half-dozen or more JavaScript and CSS pages just to make it easier to do basic wiki maintenance.

I totally agree with all of this (at least, to the extent that I understand it) -- the only reason it appears otherwise is due to my stupid misunderstanding (see above comment). Thanks again!

Peteforsyth removed Peteforsyth as the assignee of this task.Mar 8 2016, 4:48 PM