Page MenuHomePhabricator

email notification issue after email change
Closed, InvalidPublic

Description

On March the 1st I changed my Wikipedia email address and since then I haven't received any notification when a page in my watchlist is edited.

Event Timeline

Nnvu created this task.Mar 7 2016, 5:02 PM
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptMar 7 2016, 5:02 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Elitre updated the task description. (Show Details)Mar 7 2016, 5:05 PM
Elitre added a subscriber: Elitre.EditedMar 7 2016, 5:07 PM

For context, the user has switched back to his former address, and is still unable to receive said notifications.
He was able to receive direct email (via "Email this user") on both his mail accounts, but he can't receive other notifications on the one he means to use. He also couldn't receive Phab-related email.

Does the "Email this user" functionality work? When it comes to projects, I assume this is unrelated to Echo/Notifications but Wikimedia-General-or-Unknown + Mail instead?

Have you enable email notifications on Special:Preferences#mw-prefsection-echo?
Or maybe you have reset your preferences by clicking on "restore all defaults settings"?

Elitre added a comment.Mar 7 2016, 6:11 PM

Maybe you missed the update to my comment, Andre. Can you please rv? thanks.

bounce + unsubscribes + MediaWiki-extensions-BounceHandler has got something to do with this ?

Elitre added a comment.Mar 7 2016, 6:13 PM

Trizek, yes, he hasn't changed anything there AFAIK, and all the email boxes are flagged.
Actually he did switch from HTML to the other setting, but that was after the problem was confirmed (so this move didn't seem to help or to make any difference).

Maybe you missed the update to my comment, Andre. Can you please rv? thanks.

Could you clarify what would be a reason to revert changes here?

Elitre added a comment.Mar 7 2016, 6:25 PM

"Does the "Email this user" functionality work?" Yes. So AFAICT this is still in Notifications' realm?

Is the currently set email address with a freemailer such as Yahoo or Hotmail?

"Does the "Email this user" functionality work?" Yes. So AFAICT this is still in Notifications' realm?

Ah! I doubt because Phabricator email does not work either. And Phabricator does not use Echo...

Elitre added a comment.Mar 7 2016, 6:26 PM

Sure, and no problem.

Nnvu added a comment.Mar 7 2016, 7:46 PM

Or maybe you have reset your preferences by clicking on "restore all defaults settings"?

Yes, I reset all my preferences, but it was two days before changing the email address.

Is the currently set email address with a freemailer such as Yahoo or Hotmail?

I'm using a gmail address.

Catrope added a subscriber: Catrope.Mar 7 2016, 8:26 PM

@Nnvu On which wiki did this happen? (E.g. English Wikipedia?) What is your username? I looked for Nnvu but there's no user by that name.

Nnvu added a comment.Mar 7 2016, 9:21 PM

@Catrope itwiki, and my username is Fringio.

Nnvu added a comment.Mar 7 2016, 9:41 PM

I made a test, enabling the "email me when one of my edit is undone" and I recived the mail as espected.

Elitre closed this task as Invalid.Mar 7 2016, 9:46 PM

Apparently we need to get better at triaging stuff. Thanks for your help everybody.

This actually still doesn't explain the lack of email from Phab. Waiting for Nnvu to check his settings there.

Elitre added a comment.Mar 8 2016, 6:16 PM

Nnvu, see also T121105?