Page MenuHomePhabricator

Build a git repository with all the wheels required to deploy ORES
Closed, ResolvedPublic

Description

Should be a separate git repository, on gerrit, that contains all the wheels required to run ORES. See https://phabricator.wikimedia.org/T128110#2082243 for instructions on building these.

Note that they should be built on a machine with similar config to the final resting place, and hence should be a clean jessie labs box. We've set up ores-compute-01.eqiad.wmflabs specifically to be a "production-like" env. for this use.

Details

Related Gerrit Patches:
research/ores/wheels : masterAdd wheels

Event Timeline

Halfak updated the task description. (Show Details)Mar 7 2016, 7:05 PM

A note: some wheel should be ignored because the wheel maker put them in parent dependency. For example: if we have wheel for revscoring, while trying to install revscoring it returns error:

I guess it might solve it but not released yet. https://github.com/pypa/pip/pull/3372

These should definitely not be ignored - that's why there's another task to use pip freeze, which defines requirements.txt to be *fully* specified - just a list, not a tree.

Change 276310 had a related patch set uploaded (by Ladsgroup):
Add wheels

https://gerrit.wikimedia.org/r/276310

Ladsgroup added a comment.EditedMar 11 2016, 8:42 PM

@yuvipanda You're right. I found a way to bypass this issue and it's working greatly, the only thing here is that I couldn't make these wheels working without their non-python dependencies installed. Is it an expected behavior? Or am I building these wheels in incorrectly?

Ladsgroup moved this task from Backlog to Done on the Scoring-platform-team (Current) board.

Change 276310 merged by Halfak:
Add wheels

https://gerrit.wikimedia.org/r/276310

Ladsgroup closed this task as Resolved.Mar 13 2016, 8:58 AM