Page MenuHomePhabricator

Wikidata browser tests failing with "Max retries exceeded with url: /w/api.php"
Closed, ResolvedPublic

Description

All Wikidata jobs are failing:

Example error message (from browsertests-Wikidata-WikidataTests-linux-chrome-sauce):

...
0:00:01.904 ++ /srv/deployment/integration/slave-scripts/bin/mw-api-siteinfo.py http://wikidata.beta.wmflabs.org/w/api.php git_branch
00:00:02.189 Traceback (most recent call last):
00:00:02.189   File "/srv/deployment/integration/slave-scripts/bin/mw-api-siteinfo.py", line 92, in <module>
00:00:02.189     main()
00:00:02.189   File "/srv/deployment/integration/slave-scripts/bin/mw-api-siteinfo.py", line 77, in main
00:00:02.189     response = requests.get(mw_api_url, params=API_QUERY)
00:00:02.189   File "/usr/lib/python2.7/dist-packages/requests/api.py", line 55, in get
00:00:02.195     return request('get', url, **kwargs)
00:00:02.195   File "/usr/lib/python2.7/dist-packages/requests/api.py", line 44, in request
00:00:02.195     return session.request(method=method, url=url, **kwargs)
00:00:02.195   File "/usr/lib/python2.7/dist-packages/requests/sessions.py", line 455, in request
00:00:02.200     resp = self.send(prep, **send_kwargs)
00:00:02.200   File "/usr/lib/python2.7/dist-packages/requests/sessions.py", line 558, in send
00:00:02.203     r = adapter.send(request, **kwargs)
00:00:02.203   File "/usr/lib/python2.7/dist-packages/requests/adapters.py", line 378, in send
00:00:02.212     raise ConnectionError(e)
00:00:02.213 requests.exceptions.ConnectionError: HTTPConnectionPool(host='wikidata.beta.wmflabs.org', port=80): Max retries exceeded with url: /w/api.php?action=query&meta=siteinfo&siprop=general&format=json (Caused by <class 'socket.gaierror'>: [Errno -2] Name or service not known)
00:00:02.222 + MEDIAWIKI_GIT_BRANCH=
...

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 15 2016, 12:43 PM
JanZerebecki added a comment.EditedMar 15 2016, 2:14 PM
$ curl -v 'http://wikidata.beta.wmflabs.org/wiki/Wikidata:Main_Page'
* Could not resolve host: wikidata.beta.wmflabs.org

!log added wikidata.beta.wmflabs.org in https://wikitech.wikimedia.org/wiki/Special:NovaAddress to deployment-cache-text04.deployment-prep.eqiad.wmflabs

JanZerebecki closed this task as Resolved.Mar 15 2016, 3:37 PM
JanZerebecki claimed this task.