Page MenuHomePhabricator

Move users of maps-related tools to production services where possible
Closed, ResolvedPublic

Description

A lot of traffic in the Toolforge project is currently caused by tools related to maps. geohack alone is responsible for ~ 40 % of all requests.

Concurrently, there has been effort and success in setting up production services like Extension:MapSources or Extension:Kartographer that are better designed and equipped to handle most use cases and maintained by focused teams instead of lone developers.

Therefore the various wikis should – over time – switch their gadgets, links & Co. over to the new production services so that they can enjoy a better service and resources are freed up in the Toolforge project and Cloud-Services in general.

Event Timeline

scfc created this task.Mar 15 2016, 2:28 PM
Restricted Application added projects: Cloud-Services, Discovery. · View Herald TranscriptMar 15 2016, 2:28 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Yurik moved this task from All map-related tasks to Tracking on the Maps board.Mar 29 2016, 6:24 PM
TheDJ closed this task as Resolved.Jul 9 2018, 1:17 PM
TheDJ claimed this task.
TheDJ added a subscriber: TheDJ.

Some of this has happened, esp since T172065: Hunt for Toolforge tools that load resources from third party sites became more of an issue.