[betalabs] Regression: 'Mark as read/unread' box is misplaced
Closed, ResolvedPublic

Description

  1. Find a user that has not many notifications - the Notification panel should not have a vertical scroll bar
  2. Click on any of the dotdotdot menu - the box will be open in the upper left corner of the browser window.

In Chrome and FF (nothing in Console) - seems to be happening only the Notification panel is rather short - does not have a vertical scroll bar

:

Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptMar 16 2016, 8:37 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Etonkovidova renamed this task from [betalabs] Regression: 'Mark as unread' box is misplaced to [betalabs] Regression: 'Mark as read/unread' box is misplaced .Mar 16 2016, 9:06 PM
Etonkovidova updated the task description. (Show Details)

Also reproducible if you lower the text size ("zoom out") to the point where the scroll bar in the notifications popup goes away.

Catrope triaged this task as Unbreak Now! priority.Mar 16 2016, 9:58 PM

This is an OOjs-UI regression from https://gerrit.wikimedia.org/r/#/c/276664/ (for T129521). The culprit is this.needsCustomPosition = closestScrollableOfContainer !== closestScrollableOfFloatable;. This is plainly false, because (like in our case) the floatable can be in an overlay at (0,0) while the container is somewhere else, in which case positioning is definitely needed, but depending on the scrollbar situation the closest scrollable container could be the window for both of them.

Change 277908 had a related patch set uploaded (by Catrope):
Work around regression in OO.ui.FloatableElement

https://gerrit.wikimedia.org/r/277908

Change 277908 merged by jenkins-bot:
Work around regression in OO.ui.FloatableElement

https://gerrit.wikimedia.org/r/277908

Checked the fix in betalabs - 'Mark as read/unread' is positioned correctly.

jmatazzoni closed this task as Resolved.Mar 23 2016, 7:19 PM
jmatazzoni claimed this task.