No "Next" button and no error when trying to upload a file with duplicative name
Closed, ResolvedPublic


No "Next" button and no error when trying to upload a file with duplicative name,

After the description screen has been filled in, I click on Next and then I am returned to the description screen with all the fields still filled-in and no error messages and no NEXT button. There is nothing that can be done to progress the wizard to the final step. I repeated the wizard from the start and exactly the same thing happened. Help! [[User:Kerry Raymond|Kerry Raymond]]

I have successfully uploaded a number of photos earlier in the day. There was nothing particularly different about the failed one that I can see (a relatively small JPG) sourced from an out-of-copyright old newspaper (the sort of item I often upload). [[User:Kerry Raymond|Kerry Raymond]]

The file name is 'Remember Belgium.jpg' - no weird characters. 05:14, 16 March 2016 (UTC)

A file with that name was uploaded in 2009. [[File:Remember Belgium.jpg|50px]] Are you getting the error "A file with this name exists already. If you want to replace it, go to the page for File:Remember_Belgium.jpg and replace it there." [[User:Delphi234|Delphi234]]

OK, I tried to load the Remember Belgium.jpg file again. Exactly the same behaviour as before AND absolutely no error message of any kind. But at least it seems we have pinned down the bug to the case where the file name is already in use. I tried to rename the file in the Description screen which causes the "barber poll" effect on that text box as I type in other titles but doesn't cause a NEXT button to appear to progress things. [[User:Kerry Raymond|Kerry Raymond]]

matmarex created this task.Mar 17 2016, 6:44 PM
Restricted Application added a project: Multimedia. · View Herald TranscriptMar 17 2016, 6:44 PM
Restricted Application added subscribers: Steinsplitter, Aklapper. · View Herald Transcript

I always get the error like I should:

(Other than the file name being displayed with an underscore, submitted to fix that.)

A copy of the problematic file could help.

Restricted Application added a subscriber: Matanya. · View Herald TranscriptMar 18 2016, 6:54 PM
matmarex closed this task as Resolved.Apr 12 2016, 5:52 PM
matmarex triaged this task as High priority.

Thanks to T132356 I was able to reproduce this – turns out this only happens when the extension of the new file differs from the existing file only by case (e.g. "jpg" vs "JPG").

And then I realized I've already fixed it recently in, I discovered that issue separately and didn't realize it was the cause of this. But that patch fixes the big issue here (no error message and no "Next" button). It'll be deployed to Commons this Wednesday with MediaWiki version 1.27.0-wmf.21 per

UploadWizard should actually warn about this before trying to submit the files, but that's a smaller problem. I'll track that on T132356.