Page MenuHomePhabricator

MediaWiki should selects the language of the interface by user's Accept-Language first
Closed, InvalidPublic

Description

I'm using Firefox browser on Fedora 23.

MediaWiki now displays the language of the interface as the same the content by default.

For example, when you go to en.wikipedia.org, you get english interface by default and you get japanese interface for jp.wikipedia.org by default. You have to register an account and login to select the language of the interface to display.

That's not a big problem with most of the large languages, because the readers would like to read the language of the content, and they might be fine to read the language in the interface too.

However, there is an exception for Chinese. Chinese (zh) have two variants of writing styles, one is simplified Chinese characters (zh-Hans) used in mainland China, and the other one is traditional Chinese characters (zh-Hant) used in Hong Kong and Taiwan. zh uses zh-Hans for default. People have to get some additional training or learning sessions besides their normal education to read the other variant.

Now there is only one site for Chinese in Wikipedia (the major case of MediaWiki), that is zh.wikipedia.org. The content of zh site is mixed with simplified and traditional Chinese, and the site now uses a conversion program to convert the whole content into one variant that they could read easily.

So the problem is: traditional Chinese users see a site all in simplified Chinese by default, and they have to register an account and choose the language of the interface at some place they might not even know to read their native language in the whole page.

I guess this default behavior might impact some other languages which have two or more different writing systems which share the same words.

Event Timeline

Zerng07 created this task.Mar 21 2016, 3:51 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 21 2016, 3:51 PM
Zerng07 updated the task description. (Show Details)Mar 21 2016, 3:53 PM
Zerng07 updated the task description. (Show Details)
Arthur2e5 added a subscriber: Arthur2e5.EditedMar 21 2016, 7:29 PM

With Chrome on Windows 10, in incognito mode (which means no Cookies saved) and Accept-Language: en-US,en;q=0.8,zh-CN;q=0.6,zh;q=0.4, visiting https://zh.wikipedia.org gives zh-cn UI and text (expected, works). Manually switching the content language to zh-tw using the toolbar gives zh-tw UI and content (works again). Using en-US,en;q=0.8,zh-TW;q=0.6,zh;q=0.4,zh-CN;q=0.2 in incognito mode gives zh-TW UI and text (works).

Therefore, I don't think I can confirm the zh.wp part of the bug. Note that I haven't tested other Accept-Lang settings yet -- someone with firefox is probably able to test that more easily. Also, I can only tell the difference between Hans (CN/SG) and Hant (TW/MO/HK), so I might be actually seeing some HK with zh-tw set -- I don't know.

But I can confirm that in some other zh-related wiki sites, e.g. wuu, there is a significant lack of conversion schemes (no conversion available). zh-yue also seems to use some obscure js-based conversion method, which looks suboptimal compared to the zh one.

Zerng07 updated the task description. (Show Details)Mar 22 2016, 4:21 AM

Would the behavior be related to a specific browser? I will test other browsers in other platforms when I am available.

Other tests and comments are welcome.

Zerng07, would you like to try to locate the Accept-Language header in your
request so the issue can be better defined?

  • F12
  • Network Tab
  • Find the one with /wiki/Wikipedia:
  • Look at the request header

My very naive black-box guess is that your browser might be sending
something like zh-Hant-TW which is not covered in my tests.

Hi, I found my language preference settings in Firefox changed by unknown reason at some time.

The request header sent "en-US,en;q=0.5", and I have corrected it manually.

Sorry for the noise. I'm closing this bug.

Thanks for everyone's help.

Zerng07 closed this task as Invalid.Mar 22 2016, 1:51 PM