Page MenuHomePhabricator

Pywikibot 3.0
Closed, ResolvedPublic

Description

As pywikibot 2.0 is httplib2 based, and doesnt include oauth support, a Pywikibot 3.0 should be released asap. PAWS is currently using master as it needs oauth support.

Event Timeline

jayvdb created this task.Mar 22 2016, 12:58 AM
Restricted Application added subscribers: pywikibot-bugs-list, Aklapper. · View Herald TranscriptMar 22 2016, 12:58 AM
Xqt added a subscriber: Xqt.Apr 6 2016, 8:10 AM
Xqt added a comment.Apr 6 2016, 8:23 AM

I've no glue how this branches should ever work. There is a big delay from master stuff to be deployed to 2.0 branch. I remember the unsuccessful attempt to synchronize compat improvements with core (maybe vice versa to but this is not important). Now I fear we get the same problem with master to 2.0 and next 3.0. There are hundreds of files in 2.0 which are outdated against master and I guess a lot of them are stable enough to be merged to stable branch. Is there a plan and maybe any howto explanation to proceed that part.

valhallasw closed this task as Resolved.May 28 2017, 2:22 PM
valhallasw claimed this task.