Page MenuHomePhabricator

Huggle is adding warnings to watchlist when default settings are used (en.wiki)
Closed, InvalidPublic

Description

I am noticing that, ever since 3.1.20 was released, that adding warnings to talk pages also adds the user to your watchlist in the English Wikipedia.

Examples:
https://en.wikipedia.org/wiki/User_talk:Ckennon1115
https://en.wikipedia.org/wiki/User_talk:Ethmoo
https://en.wikipedia.org/wiki/User_talk:SwaggerBaller
https://en.wikipedia.org/wiki/User_talk:HistoryMan2280

This also happens with IP addresses as well (it just adds User:[IP] to the watchlist). It appears to be only happening when the first warning left is yours.

I have my warnings preferences set to "Follow your on-wiki preferences" in the interface, and my huggle.cs files do not specify this setting from default (which is 'non), or it's empty (see https://www.mediawiki.org/wiki/User:Oshwah/huggle.css and https://en.wikipedia.org/wiki/User:Oshwah/huggle.css). This didn't appear to occur in previous versions - did something change?

Event Timeline

Oshwah created this task.Mar 22 2016, 8:58 PM
Restricted Application added subscribers: Matthewrbowker, Josve05a, Aklapper. · View Herald TranscriptMar 22 2016, 8:58 PM
Oshwah updated the task description. (Show Details)Mar 22 2016, 9:01 PM
Petrb added a subscriber: Petrb.Apr 1 2016, 2:35 PM

I think it's the other way, it always was like this (when you make new page by default it's in your watchlist) but huggle was overriding this so that it is not happening, but it seems that something has changed (probably on MW) which broke this.

I will need to investigate what is it that doesn't work.

Petrb added a comment.Apr 1 2016, 2:36 PM

Btw settings is now in huggle3.css

Petrb triaged this task as High priority.Apr 2 2016, 9:08 AM
Oshwah added a comment.Apr 2 2016, 9:28 PM

Oh, good call. It is huggle3.css - I think the WP:HG page still states that it's huggle.css; I'll double check and fix if needed.

Petrb closed this task as Invalid.Sep 29 2016, 11:10 PM

It works to me when I change watchlist settings to "do nothing" on-wiki preferences by default add newly created pages so that is probably a reason, not a bug in huggle, more a problem of MW.