Page MenuHomePhabricator

Edit conflict not triggered, undoing the earlier changes
Closed, InvalidPublic

Description

Wikitext edits don't trigger edit conflict with earlier VisualEditor edits, undoing the changes, or at least, I have two cases where this happened. (Reported at https://pl.wikipedia.org/wiki/Dyskusja_wikipedysty:Matma_Rex#dziwne_edycje)


Example 1: https://pl.wikipedia.org/wiki/Komitet_Obrony_Demokracji, snippet from edit history:

VersionDiffAuthorEdit summary
4538761445387614Adamtdrobne redakcyjne
4538742245387422Fugieldrobne redakcyjne
4538738945387389Fugielźródło [VisualEditor]

Adamt's edit overwrote the previous two edits by Fugiel (in addition to making the single change he intended): https://pl.wikipedia.org/w/index.php?title=Komitet_Obrony_Demokracji&diff=45387614&oldid=45387322


Example 2: https://pl.wikipedia.org/wiki/Shane_McMahon

VersionDiffAuthorEdit summary
4539053945390539Adamtmistrzostwo się zdobywa, pas znajduje
4539044745390447TheGLUTHPoprawki nagłówków, podpisu pod zdjęciem [VisualEditor]
4539043445390434TheGLUTHDrobne zmiany linków [VisualEditor: switched]

Again, Adamt's edit overwrote the previous two: https://pl.wikipedia.org/w/index.php?title=Shane_McMahon&type=revision&diff=45390539&oldid=45390367

Event Timeline

matmarex created this task.Mar 25 2016, 9:38 PM
Restricted Application added a project: VisualEditor. · View Herald TranscriptMar 25 2016, 9:38 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Cannot reproduce on localhost

Possibly a malfunctioning script/gadget from the user? It's the same user in both circumstances…

Jdforrester-WMF changed the task status from Open to Stalled.Apr 12 2016, 7:24 PM
Deskana closed this task as Invalid.Aug 27 2018, 1:42 PM