Page MenuHomePhabricator

<strong>Notifications - the whole page is bold
Closed, ResolvedPublic

Description

Special:Notifications - the whole page (including sidebar, personal links etc) is in BOLD

How to reproduce:

  • //he.wikipedia.org/wiki/Special:Notifications

Issues:

  1. It seems there is unclosed strong tag causing the whole page to appear in bold
  2. The page is very strong... e.g it contains many strong tags. For example each .mw-echo-state div contains double strong which is redundant for example:
<div class="mw-echo-state"><strong><strong><img src="/w/extensions/Echo/modules/icons/edit-user-talk.svg" class="mw-echo-icon"><div class="mw-echo-content"><div class="mw-echo-title">2 הודעות חדשות בדף השיחה שלך</div>
<div class="mw-echo-notification-footer"><span class="mw-echo-notification-footer-element">לפני יום 1</span><span class="mw-echo-notification-footer-element"> | </span><a class="mw-echo-notification-footer-element" href="//he.wikipedia.org/wiki/%D7%A9%D7%99%D7%97%D7%AA_%D7%9E%D7%A9%D7%AA%D7%9E%D7%A9:%D7%A2%D7%A8%D7%9F">הצגת הודעה</a><span class="mw-echo-notification-footer-element"> | </span><a class="mw-echo-notification-footer-element" href="//he.wikipedia.org/w/index.php?title=%D7%A9%D7%99%D7%97%D7%AA_%D7%9E%D7%A9%D7%AA%D7%9E%D7%A9:%D7%A2%D7%A8%D7%9F&amp;oldid=18338350&amp;diff=18338505">הצגת שינויים</a></div>
</div></strong></strong></div>

Event Timeline

eranroz created this task.Mar 28 2016, 5:45 PM
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptMar 28 2016, 5:45 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Etonkovidova added a subscriber: Etonkovidova.EditedApr 8 2016, 12:56 AM

There is a similar case with monospace font in betalabs.

The Notifications page changes its font if some of the Notifications have <pre> in them (there is one case - not reproducible).

Resolving topics sends notifications where topic titles are parsed (true for <pre>, <tt>, <strong>, <code> tags in titles).

Steps to reproduce the issue described in the ticket:

  1. On a Flow board that a some user watches, create a topic with "<strong>Bold text" as a title(no quotes).
  2. A user, who watches the board, receives a normal notification with the title displayed as it is.
  3. Resolve the topic - the user receives a notification where the topic will be parsed - The topic "‪Bold text‬" was resolved. (the tag <strong> is missing).
  4. Go to the Notification page - the whole page will be displayed in bold:

Change 283114 had a related patch set uploaded (by Catrope):
Use plaintext for topic titles in resolved notification

https://gerrit.wikimedia.org/r/283114

Change 283114 merged by jenkins-bot:
Use plaintext for topic titles in resolved notification

https://gerrit.wikimedia.org/r/283114

Checked the fix in betalabs (including <pre>, <tt>, <code> and templates (for regression)).
Tags in topic titles'

  • are not parsed
  • do not affect the display of Notifications page
jmatazzoni closed this task as Resolved.Apr 15 2016, 9:11 PM
Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptApr 19 2016, 9:02 PM
  1. In hewiki that sidebar still appears as bold in Special:Notifications in my account ("User:ערן" )
  2. I wanted to grab a screenshot and since (most of) the Collab-Team don't read Hebrew yet I moved to uselang=en and the problem doesn't appear in English. Could this <strong> be somehow cached (server side)?

@Catrope, this was resolved on the 15th and @eranroz reported it again on the 18th. Is this because the fix wasn't live yet? If so, is it now/when will it be? I.e., how long should eranroz wait to report if he sees it again?

It was merged April 13, and he reported it Wednesday (May 18), so it's not just deployment train lag.

jmatazzoni reopened this task as Open.May 19 2016, 10:11 PM

Matt says:

so it's not just deployment train lag.

I'll move this to QA to see if @Etonkovidova can reproduce. If so, Elena, please move back to In Dev. Thanks. If not, let's close again and wait to see what happens.

From @eranroz's comment it sounds like it may be specific to viewing in Hebrew: possibly a mistake in the translation.

eranroz closed this task as Resolved.May 20 2016, 2:28 PM
eranroz added a subscriber: Amire80.

@Catrope good catch: 1 2 3. (@Amire80 accidentally updated only the start tag)