Page MenuHomePhabricator

Mobile donation form: error entering valid email address NL-iDEAL
Closed, ResolvedPublic1 Story Points

Description

Two donors today were unable to enter an email address on the donation form. The donor in ZD #216095 provided a good screenshot of what they saw on mobile, using Chrome on a Samsung Note4. We were unable to replicate this error on desktop browsers. The donor in
#216363 has an email in the format of x_xx_xxxxxx@hotmail.com, with two underscores before the @.

We'll add more documentation here as we encounter more of this; volume is low so far, so calling priority normal.

Event Timeline

MBeat33 created this task.Mar 30 2016, 10:19 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 30 2016, 10:19 PM
MBeat33 triaged this task as Normal priority.Mar 30 2016, 10:19 PM
MBeat33 raised the priority of this task from Normal to High.Apr 4 2016, 3:10 PM

The donor in the screenshot is in Zendesk #217303, they used a Samsung S5 Neo with Firefox; we're also following up with the donor in #217369. Both screenshots so far are from iDEAL donors. As this is a donor facing error in an active campaign, I'm bumping the priority to high.

MBeat33 renamed this task from Mobile donation form: error entering valid email address to Mobile donation form: error entering valid email address NL-iDEAL.Apr 4 2016, 3:10 PM
DStrine raised the priority of this task from High to Unbreak Now!.Apr 4 2016, 10:05 PM
DStrine added a subscriber: DStrine.

adding to sprint. The Netherlands campaign runs until 4/26. We should at least look into this

awight claimed this task.Apr 4 2016, 10:06 PM
awight moved this task from Backlog to Doing on the Fundraising Sprint Ghostbusting board.

I was hoping it was just a pattern= attribute that we were setting on the input, but that doesn't seem to be the case. My next guess is that it's a bad default pattern on some phones, so I'll try to override with a more liberal regex.

Nope--terrible guess. The error is coming from our server-side validation.

I'm seeing more strange behavior on this form.

  • Entering an invalid address in desktop Firefox causes the submit button to do nothing, but with no feedback.
  • The fields are optional, but I believe we intended them to be required.

Let's focus on the "ideal mustache" task, T128693, as a long-term solution for this and related issues.

@awight T128693 is not in the sprint and currently at 4 points. Is there a short term fix? The campaign has been live and will be up until 4/26.

Specific steps to reproduce the first bug I mentioned above:

Nothing happens. No console error, no server communication.

The "nothing happens" bug is caused by client-side validation which is written for the "red highlight" forms. It correctly notes the failure, but nothing shows up due to missing CSS.

I found a third bug, where a leading or trailing space will break server-side email validation. We should be more liberal than that--phones like to add spaces.

Change 281581 had a related patch set uploaded (by Awight):
Trim email during normalization

https://gerrit.wikimedia.org/r/281581

Remaining bugs should be fixed in T131821

Change 281581 merged by jenkins-bot:
Trim email during normalization

https://gerrit.wikimedia.org/r/281581

awight closed this task as Resolved.Apr 6 2016, 12:34 AM
awight moved this task from Pending Deployment to Done on the Fundraising Sprint Ghostbusting board.

I've fixed the first guess at the cause of this problem, now trailing space is allowed and will be trimmed from the final email address.

Please reopen if the issue is reported again!

Thanks, @awight - donors like #217429 who got this error are now able to donate via iDEAL

awight added a comment.Apr 7 2016, 9:52 PM

Thanks for the good news!

awight set the point value for this task to 1.Apr 12 2016, 9:59 PM