Page MenuHomePhabricator

Uncaught TypeError: Cannot read property 'replace' of null
Closed, ResolvedPublic1 Story Points

Description

When I try to load https://www.mediawiki.org/w/index.php?title=Help:Extension:Kartographer&veaction=edit I get Uncaught TypeError: Cannot read property 'replace' of null in console.

Event Timeline

MaxSem created this task.Apr 1 2016, 7:03 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 1 2016, 7:03 AM

The problem is kartographer generates a link. Because there is no VE support for kartographer link mode it falls back to regular VE link handling, but kartographer generates no href, which is what is generating the exception. We should add a node for kartographer links, even just to say they are un-editable for now.

Change 281183 had a related patch set uploaded (by Esanders):
Only detect plain external links if they have href's

https://gerrit.wikimedia.org/r/281183

Change 281183 merged by jenkins-bot:
MWExternalLinkAnnotation: Only match plain external <a>s with hrefs

https://gerrit.wikimedia.org/r/281183

Jdforrester-WMF triaged this task as High priority.
Jdforrester-WMF removed a project: Patch-For-Review.
Jdforrester-WMF set the point value for this task to 1.
Jdforrester-WMF moved this task from To Triage to TR0: Interrupt on the VisualEditor board.
Jdforrester-WMF closed this task as Resolved.Apr 5 2016, 3:32 PM
Restricted Application added a project: Discovery. · View Herald TranscriptJun 12 2016, 2:59 AM