Page MenuHomePhabricator

MW-1.27.0-wmf.23 deployment blockers
Closed, ResolvedPublic

Details

Related Gerrit Patches:
operations/mediawiki-config : masterGroup0 to php-1.27.0-wmf.23
mediawiki/tools/release : mastermake-wmf-branch: drop mw cherry pick
mediawiki/core : wmf/1.27.0-wmf.23Validate wmf/1.27.0-wmf.23 (DO NOT SUBMIT)

Event Timeline

greg created this task.Apr 1 2016, 10:09 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 1 2016, 10:09 PM
greg moved this task from INBOX to Backlog on the Release-Engineering-Team board.Apr 1 2016, 11:07 PM
hashar moved this task from Next to In-progress on the Release-Engineering-Team board.

Mentioned in SAL [2016-05-03T12:07:33Z] <hashar> Cutting 1.27.0-wmf.23 branches T131557

Change 286635 had a related patch set uploaded (by Hashar):
make-wmf-branch: drop mw cherry pick

https://gerrit.wikimedia.org/r/286635

Add a conflicting cherry pick which is no more needed https://gerrit.wikimedia.org/r/#/c/274165/3 for T124356

Change 286636 had a related patch set uploaded (by Hashar):
Validate wmf/1.27.0-wmf.23 (DO NOT SUBMIT)

https://gerrit.wikimedia.org/r/286636

Change 286636 abandoned by Hashar:
Validate wmf/1.27.0-wmf.23 (DO NOT SUBMIT)

Reason:
pass

https://gerrit.wikimedia.org/r/286636

Add a conflicting cherry pick which is no more needed https://gerrit.wikimedia.org/r/#/c/274165/3 for T124356

Applied all local patches. Dropped one that got released T133700

Change 286641 had a related patch set uploaded (by Hashar):
Group 0 to php-1.27.0-wmf.23

https://gerrit.wikimedia.org/r/286641

Mentioned in SAL [2016-05-03T13:10:32Z] <hashar@tin> Started scap: testwiki to php-1.27.0-wmf.23 and rebuild l10n cache T131557

Mentioned in SAL [2016-05-03T13:37:26Z] <hashar@tin> Finished scap: testwiki to php-1.27.0-wmf.23 and rebuild l10n cache T131557 (duration: 26m 54s)

Mentioned in SAL [2016-05-03T13:38:58Z] <hashar> Warming up HHVM cache hitting testwiki T131557

Mentioned in SAL [2016-05-03T13:51:52Z] <hashar> Warming up HHVM cache hitting testwiki /w/api.php T131557

hashar added a subscriber: aude.May 3 2016, 2:06 PM

Not much to worry about so far ;-)

@aude going to bump Wikibase

Synced Wikidata .23

sync-dir php-1.27.0-wmf.23/extensions/Wikidata 'wikidata to .23 https://gerrit.wikimedia.org/r/#/c/286657/'

Change 286635 merged by jenkins-bot:
make-wmf-branch: drop mw cherry pick

https://gerrit.wikimedia.org/r/286635

Change 286641 merged by jenkins-bot:
Group0 to php-1.27.0-wmf.23

https://gerrit.wikimedia.org/r/286641

Mentioned in SAL [2016-05-03T19:01:42Z] <hashar@tin> rebuilt wikiversions.php and synchronized wikiversions files: group0 to 1.27.0-wmf.23 T131557

Mentioned in SAL [2016-05-04T20:28:25Z] <hashar@tin> rebuilt wikiversions.php and synchronized wikiversions files: Wikidata back to 1.27.0-wmf.22 due to T134432. Poke T131557.

Luke081515 updated the task description. (Show Details)May 4 2016, 9:53 PM
Luke081515 updated the task description. (Show Details)May 4 2016, 9:57 PM

1.27.0-wmf.23 got rollbacked to 1.27.0-wmf.22 due to a performance regression T134553: First paint time regression on Wikimedia page views with wmf.23 roll-out.

greg added a comment.May 9 2016, 3:20 PM

Per T134553#2275914 we're good to go with wmf.23 again.

greg added a comment.May 9 2016, 3:41 PM

maybe spoke too soon..... let's confirm with Gilles before moving forward

Gilles added subscribers: ori, Gilles.May 9 2016, 3:50 PM

If you guys have the bandwidth for it, we can backport the suspicious change to wmf22 first, as @hashar and @ori have suggested. I'm not sure it will give us all the answers, since some of the regression appears to be "sticky" and have survived the revert to wmf22. But it certainly won't hurt.

Gilles added a comment.May 9 2016, 4:12 PM

@greg can someone from releng deploy this backport for me? https://gerrit.wikimedia.org/r/287654

Looks like we want to deploy 1.27.0-wmf.23 again this Monday. Make sure it is all happy and if tomorrow it still fine we can resume the regular deployment schedule (i.e. 1.28.0-wmf.1).

Gilles closed this task as Resolved.May 10 2016, 7:23 AM

wmf.23 redeployed yesterday