Technical Collaboration quarterly goals for July - September 2016
Closed, ResolvedPublic

Description

Goals will be documented on https://meta.wikimedia.org/wiki/Technical_Collaboration/Goals

Team quarterly goals

Individual quarterly goals

Individual goals are documented in the table below.

OwnerGoals
@AklapperT137214: A process to use available information about new and leaving technical contributors, T129067: Document a structured, standardized approach for reviewing code contributions (continue from last quarter)
@CKoerner_WMFT137312: Work with communities to learn how inter-wiki search might work, T127002: Look into producing a list of frequent 'zero result' search terms on Wikimedia projects, T139369: Better promote ways volunteer developers can be involved in Discovery projects, T139370: Share results of Hovercard A/B Test on Hungarian Wikipedia
@ElitreT135819: Documentation of daily activities and responsibilities of CLs and Product teams, T137571: Phases 2, 3 in building a volunteer, cross-wiki taskforce to help with the community side of VE work, T137572: Cleanup of community-related documentation on Office wiki
@JohanT128790: Translation strategy – act and refine, T141358: Support Community Tech through a successful process of selecting Education/Program wishes, T141357: Support ORES
@KeeganT137826: Recommendations for announcing new project proposals, T138339: Create a systematic approach to community engagement for product development teams, T137825: Recommendations for publishing project updates, T120070: Recommendation for projects requesting prioritization or resources
@MoushiraT121647: Explore a process for UX/UI discussion, T141354: Discuss, with communities, adding Wikidata desc to mobile web underneath title , T139793: let communities know that lang button is moving on mobile
@RfarrandT132398: Developer Summit: Research Other Venues, T132107: Publish Lessons Learned from Wikimedia Hackathon 2016, T132109: Possibility to have scholarships / prizes to send great Wikimedia Hackathon developers to Wikimania Hackathon., T141927: Open Registration for the Wikimedia Developer Summit, T141939: Contract the Golden Gate Club for the Wikimedia Developer Summit
@QgilT137801: Hire a Developer Advocate for the Technical Collaboration team - T1035: Consolidate the many tech events calendars in Phabricator's calendar - T131689: Second iteration of the Technical Collaboration strategy
@QuiddityT136866: Improve the per-programming-language listings for our tools - Continue with T130095: A plan for the top ten Community Wishlist tasks driven by volunteers - T141810
@Trizek-WMFT125632: Plan, write and submit a satisfaction survey concerning Flow to communities ; T130730: Draft and review a public announcement concerning Flow support ; T123538: Rethink the way we communicate with communities concerning Collaboration team work as a practical case for Keegan's work
@Whatamidoing-WMFT134580: CLs to communicate the Save/Publish changeT136674: Help contact bot owners about the end of HTTP access to the API – Begin (but not finish) T137317: Inform communities about planned outages caused by the server switch (April 2017?)

Calendar

  • 2016-06-06: Community Engagement department goals (if we have proposals, they need to be pushed before)
  • 2016-06-14: Team quarterly goals must be committed to CE and the WMF.
  • 2016-06-21: Soft deadline for individual goals.
  • 2016-06-30: Definition of individual goals completed.
  • 2016-10-12: Quarterly review dry run. Materials must be in place.
  • 2016-10-17: Quarterly review

Related Objects

There are a very large number of changes, so older changes are hidden. Show Older Changes
Qgil added a comment.Jun 2 2016, 6:44 AM

No goal related to our annual plans on #community-wishlist-survey (Program 8)? Program 7 is covered in the goals proposed.

No goal related to our annual plans on #community-wishlist-survey (Program 8)? Program 7 is covered in the goals proposed.

I think that's just "Regular workflows" now.
Although we could repeat "A plan for the top ten Community Wishlist tasks driven by volunteers" with another 10?
I'm also considering this as a personal goal: T136866: Improve the per-programming-language listings for our tools

Qgil added a comment.Jun 2 2016, 9:53 PM

I'd rather focus deeper on the 10 tasks we commit to in this quarter rather than trying to embrace too much by adding 10 more... I don't know, what do you (plural) think?

In any case, if there is no clear goal for the CW in this quarter, then there is no need to force one.

Elitre edited the task description. (Show Details)Jun 7 2016, 10:19 AM
Qgil edited the task description. (Show Details)Jun 7 2016, 12:32 PM
Aklapper edited the task description. (Show Details)Jun 7 2016, 4:00 PM
Elitre edited the task description. (Show Details)Jun 10 2016, 4:37 PM
Elitre added a comment.EditedJun 10 2016, 4:56 PM

I took the VE task (T96500) out of my goals, because it doesn't relate directly with Editing's goals for this Q as far as I understand them, and since I haven't been able to figure out what the plans are for further rollouts, I _will_ keep it as something I work on (obviously), but I don't want to commit to a quarterly goal.

Trizek-WMF added a comment.EditedJun 14 2016, 10:48 AM

My goals:

I'm lowering the previous ones, due to a lack of time. I prefer to focus on daily work about products that have an important community input instead of more theoretical (but still important) tasks.

I'm still watching your work and supporting you, guys.

Trizek-WMF edited the task description. (Show Details)Jun 14 2016, 10:49 AM
Qgil edited the task description. (Show Details)Jun 14 2016, 12:55 PM
Qgil edited the task description. (Show Details)Jun 14 2016, 1:02 PM
Qgil lowered the priority of this task from "High" to "Normal".Jun 14 2016, 1:04 PM

The team quarterly goals have been decided. Some documentation is still pending.

Individual goals are being discussed, some team members are all set while others are still thinking about the best choices.

We are in a good pace to complete the selection and documentation of these goals by the end of this month.

Keegan edited the task description. (Show Details)Jun 14 2016, 5:59 PM
Aklapper edited the task description. (Show Details)Jun 26 2016, 3:08 PM
Aklapper edited the task description. (Show Details)

We have agreed our team goals on time, but there is still some more work to do with individual goals. I hope we can complete the list of individual goals by the end of Thursday, July 7.

Rfarrand edited the task description. (Show Details)Jul 1 2016, 1:08 PM
CKoerner_WMF edited the task description. (Show Details)Jul 2 2016, 3:38 AM
Qgil moved this task from Backlog to July on the Community-Liaisons (Jul-Sep-2016) board.
CKoerner_WMF edited the task description. (Show Details)Jul 5 2016, 3:40 PM
CKoerner_WMF edited the task description. (Show Details)Jul 5 2016, 3:47 PM
CKoerner_WMF edited the task description. (Show Details)Jul 5 2016, 3:50 PM
Qgil edited the task description. (Show Details)Jul 5 2016, 5:46 PM
Quiddity edited the task description. (Show Details)Jul 6 2016, 8:33 PM
Qgil added a comment.Jul 8 2016, 2:30 PM

Update on individual goals:

Moushira edited the task description. (Show Details)
Johan edited the task description. (Show Details)Jul 26 2016, 1:51 PM
Johan edited the task description. (Show Details)
Trizek-WMF edited the task description. (Show Details)Jul 27 2016, 2:37 PM

I've updated my goals:

There are still a couple of people that need to document here the goals agreed in 1:1 conversations (last week). I am hoping to see the list of individual goals completed by the end of this week. We can blame Summer vacation for the delay.

Rfarrand edited the task description. (Show Details)Aug 2 2016, 10:14 PM
Rfarrand edited the task description. (Show Details)
Qgil edited the task description. (Show Details)Aug 8 2016, 8:51 AM

Individual goals finally defined by all team members. The review of this quarter will happen at some point in October.

Qgil moved this task from Backlog to October on the Developer-Relations (Oct-Dec-2016) board.
Qgil edited the task description. (Show Details)Aug 8 2016, 9:04 AM
Qgil lowered the priority of this task from "Normal" to "Low".
Qgil edited the task description. (Show Details)Sep 21 2016, 6:55 AM
Qgil raised the priority of this task from "Low" to "Normal".Sep 27 2016, 1:07 PM
Qgil edited the task description. (Show Details)Sep 29 2016, 5:42 AM
Qgil raised the priority of this task from "Normal" to "High".Oct 5 2016, 9:21 AM
Qgil lowered the priority of this task from "High" to "Normal".Oct 10 2016, 3:09 PM

I have done the bulk of the homework. I still have to react to feedback and, of course, deliver the review (dry run and the real one).

Qgil added a comment.Oct 18 2016, 6:28 AM

Both the dry run and the quarterly review went in my opinion well, in terms of delivering a concise message about our activities, our motivation behind them, the outcomes, and a glimpse of how these achievements in the previous quarter are continuing in this quarter. I didn't get any questions in the quarterly review, which might mean that everything was very clear or something different...

I will close this task as soon as the quarterly review slides have been published.

Qgil edited the task description. (Show Details)Nov 9 2016, 10:48 AM
Qgil closed this task as "Resolved".
Qgil moved this task from October to November on the Community-Liaisons (Oct-Dec-2016) board.
Qgil moved this task from October to November on the Developer-Relations (Oct-Dec-2016) board.