Page MenuHomePhabricator

Creation of SVG thumbnail preview on Special:Upload never finishes when trying to upload (invalid?) new file version on Commons
Closed, ResolvedPublic

Description

STEPS TO REPRODUCE:

  1. Go to https://commons.wikimedia.org/wiki/File:Community_Engagement_-_Maps_of_teams_and_workflows.svg
  2. Click "Upload a new version of this file"
  3. End up on https://commons.wikimedia.org/w/index.php?title=Special:Upload&wpDestFile=Community_Engagement_-_Maps_of_teams_and_workflows.svg&wpForReUpload=1
  4. Under "Source File > Source Filename", choose your local SVG file (Testcase under cc-by-sa-4.0: F3852629) which was created by downloading the original SVG version (created in "Adobe Illustrator") and then editing it in "Inkscape".
  5. Wait for the preview to successfully render

ACTUAL OUTCOME:

  • Preview rendering does not finish; spinner shown forever (I waited for 15 minutes):

  • Browser console in Firefox says: prefix not bound to a namespace refering to line 3398 of F3852629 being id="XMLID_3529_" /></g></g><i:pgf

EXPECTED OUTCOME:

Under the assumption that the SVG is invalid and cannot be rendered,

  • have a timeout to stop trying rendering and show some message like "Failed to create file preview"
  • or bonus points for showing some more informative error message actually explaining what went wrong (and whether that will also affect the file upload itself to not waste my time trying to continue, because I'll get a validation error anyway if I continue)

SEE ALSO:

For historical reasons, T37870: Pre-upload thumbnail shows spinner, never finishes on Windows 8 Consumer Preview / IE 10

Event Timeline

Aklapper created this task.Apr 9 2016, 9:39 AM
Restricted Application added a project: Multimedia. · View Herald TranscriptApr 9 2016, 9:39 AM
Restricted Application added a subscriber: Steinsplitter. · View Herald Transcript
matmarex claimed this task.Apr 14 2016, 9:22 PM
matmarex triaged this task as Low priority.
Restricted Application added a subscriber: Matanya. · View Herald TranscriptApr 14 2016, 9:22 PM

Change 283567 had a related patch set uploaded (by Bartosz Dziewoński):
mediawiki.special.upload: Don't fail when trying to thumbnail invalid file

https://gerrit.wikimedia.org/r/283567

Change 283567 merged by jenkins-bot:
mediawiki.special.upload: Don't fail when trying to thumbnail invalid file

https://gerrit.wikimedia.org/r/283567

matmarex closed this task as Resolved.Apr 16 2016, 1:28 PM
matmarex removed a project: Patch-For-Review.
Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptApr 19 2016, 11:02 PM