UploadWizard does and does not handle duplicate file names with different capitalization of file extension at the same time
Closed, ResolvedPublic

Description

See original description at commons.

Assume test.JPG already exists. Then while trying to upload test.jpg, clicking "next" during the last step only brings you back to the "describe" step without an error message. Seems like test.JPG and test.jpg are treated as two different file names for most of the process, but not in the last step?

El_Grafo created this task.Apr 11 2016, 4:29 PM
Restricted Application added a project: Multimedia. · View Herald TranscriptApr 11 2016, 4:29 PM
Restricted Application added subscribers: Steinsplitter, Aklapper. · View Herald Transcript
El_Grafo moved this task from Incoming to Uploading on the Commons board.Apr 11 2016, 4:38 PM
Restricted Application added a subscriber: Matanya. · View Herald TranscriptApr 11 2016, 4:38 PM
matmarex claimed this task.
matmarex triaged this task as High priority.
matmarex removed a project: MediaWiki-Uploading.
matmarex added a subscriber: matmarex.

This is actually a duplicate of T130242, but that didn't have reproduction steps, so – thank you! I finally connected the dots and that issue is fixed now (there's an error message explaining the problem and the user doesn't get stuck).

But yeah, we should detect this earlier. I'll look into this.

Change 283005 had a related patch set uploaded (by Bartosz Dziewoński):
mw.DestinationChecker: Check for non-exact extension matches too

https://gerrit.wikimedia.org/r/283005

matmarex lowered the priority of this task from High to Normal.Apr 12 2016, 8:04 PM

Change 283005 merged by jenkins-bot:
mw.DestinationChecker: Check for non-exact extension matches too

https://gerrit.wikimedia.org/r/283005

Restricted Application added a subscriber: Poyekhali. · View Herald TranscriptApr 18 2016, 6:03 PM
matmarex closed this task as Resolved.Apr 19 2016, 3:27 PM
matmarex removed a project: Patch-For-Review.

This has been fixed and the fix will be deployed to Wikimedia Commons on Wednesday, 27 April 2016, with MediaWiki version 1.27.0-wmf.22, per https://www.mediawiki.org/wiki/MediaWiki_1.27/Roadmap.

Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptApr 19 2016, 3:27 PM