Page MenuHomePhabricator

HTTPS redirects for transparency.wikimedia.org
Closed, ResolvedPublic

Description

Enabling this is trivial, the question is: is there any reason we *can't* enable this? Who's responsible for this service and might know of exceptions like mixed-content, or HTTPS-incapable tools which rely on it, etc? [note this a generic message being tacked into the description of several similar tickets]

Related Objects

StatusAssignedTask
Resolvedema
OpenBBlack
OpenBBlack
ResolvedBBlack
ResolvedArielGlenn
ResolvedChmarkine
ResolvedBBlack
ResolvedBBlack
ResolvedBBlack
ResolvedBBlack
ResolvedBBlack
ResolvedBBlack
ResolvedCCogdill_WMF
DeclinedBBlack
DuplicateBBlack
ResolvedBBlack
ResolvedBBlack
ResolvedBBlack
ResolvedBBlack
ResolvedBBlack
ResolvedBBlack
ResolvedBBlack
ResolvedBBlack

Event Timeline

BBlack created this task.Apr 12 2016, 3:44 PM

I don't see any mixed content in simple checks, and it seems to not use proto-absolute URLs in general. Since this site is clearly for human consumption, I'll probably enable the HTTPS redirect shortly if no objections come up.

Redirect to https should be fine, since we enabled HSTS for transparency.wikimedia.org in May 2015.[1] But was there any reason that the redirect was dropped?

[1] https://gerrit.wikimedia.org/r/#/c/199517/

@Chmarkine: not sure - those changes are still in puppet, and I've confirmed the backend server for it today (bromine) still has that config deployed as well. But in practice, http://transparency.wikimedia.org/ does not return a redirect... in any case, when we fix it at the cache_misc level it'll be fixed for sure.

Change 283203 had a related patch set uploaded (by BBlack):
transparency.wm.o HTTPS redirect T132464

https://gerrit.wikimedia.org/r/283203

Change 283203 merged by BBlack:
transparency.wm.o HTTPS redirect T132464

https://gerrit.wikimedia.org/r/283203

BBlack closed this task as Resolved.Apr 13 2016, 3:35 PM
BBlack claimed this task.