Page MenuHomePhabricator

API fallback (broken) title shown for mention notification
Closed, ResolvedPublic

Description

Hi. I have nothing to say. Just look at this:


And I get the same in daily mail. Thank you.

Event Timeline

IKhitron created this task.Apr 17 2016, 1:11 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 17 2016, 1:11 PM

@IKhitron Can you make a screenshot, where you append ?uselang=en to URL, to make it readable to the most developers? Thanks.

I don't think there will be important differences, but here you are:

ok, thanks. In general it makes the screenshot for people like me better readable, because I normally don't read from the right to the left side ;).

Luke081515 triaged this task as High priority.Apr 17 2016, 2:10 PM

Is the linked page a Flow board or regular wikitext page?

Mattflaschen-WMF renamed this task from Weird notification to API fallback (broken) title shown for mention notification.Apr 18 2016, 6:52 PM

A regular page. Otherwise I would connect flow project, of course.

It's 583214.

I managed to reproduce this eventually; the edit that triggered it was https://he.wikipedia.org/w/index.php?title=%D7%9E%D7%A9%D7%AA%D7%9E%D7%A9:Roan_Kattouw_(WMF)/Sandbox&oldid=prev&diff=18498914 .

It seems that the template is parsed twice, because if I test with {{תב|תב}} as the section name (the Hebrew equivalent of {{tl|tl}}) I get this:


and I can reproduce that on localhost by creating a section with == {{tl|tl}} == and pinging a user in that section.

Catrope claimed this task.Apr 18 2016, 11:55 PM
Catrope moved this task from Untriaged to In Development on the Collab-Team-2016-Apr-Jun-Q4 board.

Change 284119 had a related patch set uploaded (by Catrope):
Use plaintextParams() for snippets and sections

https://gerrit.wikimedia.org/r/284119

Change 284119 merged by jenkins-bot:
Use plaintextParams() for snippets and sections

https://gerrit.wikimedia.org/r/284119

Checked in betalabs - for templates in section titles on wikitext based pages.

A template in the section title (e.g. == {{tl|tl}} == was used) does not mess up the layout anymore or display any errors.

@Catrope
In a notification, there is small part of section title code gets exposed - i.e. == .



The post was:

== {{tl|tl}} ==
[[User:Etonkovidova]] ~~~~

 =={{תב|תב}} ==
[[User:ET1]] ~~~~

Since there is general inconsistency in displaying transclusions as plain text between Flow board topic titles and wikitext pages section titles, the issue was filed as {T133319: Transclusions in section titles on wikitext pages not displayed as plain text in Notifications}.

jmatazzoni closed this task as Resolved.Apr 22 2016, 4:31 PM