Page MenuHomePhabricator

UploadWizard doesn't handle errors caused by upload rate limiting
Closed, ResolvedPublic

Description

UploadWizard doesn't handle errors caused by upload rate limiting ($wgRateLimits).

Details

Related Gerrit Patches:
mediawiki/extensions/UploadWizard : masterHandle errors caused by upload rate limiting
mediawiki/core : masterAdd 'api-error-ratelimited' message for UploadWizard

Event Timeline

matmarex created this task.Apr 18 2016, 3:09 PM
Restricted Application added a project: Multimedia. · View Herald TranscriptApr 18 2016, 3:09 PM
Restricted Application added subscribers: Steinsplitter, Aklapper. · View Herald Transcript
matmarex claimed this task.Apr 18 2016, 9:03 PM
Restricted Application added a subscriber: Matanya. · View Herald TranscriptApr 18 2016, 9:03 PM
Jdforrester-WMF triaged this task as Medium priority.Apr 25 2016, 11:08 PM
matmarex raised the priority of this task from Medium to High.Apr 26 2016, 8:36 PM

Change 285562 had a related patch set uploaded (by Bartosz Dziewoński):
Add 'api-error-ratelimited' message for UploadWizard

https://gerrit.wikimedia.org/r/285562

Change 285564 had a related patch set uploaded (by Bartosz Dziewoński):
Handle errors caused by upload rate limiting

https://gerrit.wikimedia.org/r/285564

A test with $wgRateLimits['upload']['user'] = [ 3, 60 ] (3 uploads per minute):

Change 285562 merged by jenkins-bot:
Add 'api-error-ratelimited' message for UploadWizard

https://gerrit.wikimedia.org/r/285562

Change 285564 merged by jenkins-bot:
Handle errors caused by upload rate limiting

https://gerrit.wikimedia.org/r/285564

matmarex closed this task as Resolved.May 2 2016, 4:01 PM

This should be deployed to Wikimedia Commons this Wednesday.