Page MenuHomePhabricator

Somebody is able to suppress redirect without permission to do that
Closed, InvalidPublic

Description

Hi, I saw a bug at cswiki. See log https://cs.wikipedia.org/w/index.php?title=Speci%C3%A1ln%C3%AD%3AProtokolovac%C3%AD_z%C3%A1znamy&type=move&user=Dvorapa&page=&year=&month=-1&tagfilter=&subtype= . One of examples is a move what happened today (21th April 2016) at 9:00 UTC (11:00 CEST).

User Dvorapa is able to suppress redirect when he moves pages in module namespace. He isn't able to move subpages in module namespace, only root pages. He is in autopatrol and autoconfirmed user group which hasn't this right at cswiki. I am not able to reproduce this issue which my test account (UrbanecmTest) which is in autoconfirmed user group only. I'll ask others wikipedians at our village pump (https://cs.wikipedia.org/wiki/Wikipedie:Pod_l%C3%ADpou ) if they are able to do it.

Steps to move modul page with suppressing redirect

  1. Click move button in More menu when logged in with autoconfirmed and autopatroll account (without sysop group) configured as at cswiki
  2. Move page
  3. System doesn't create redirect

I think that is important issue because it can happen (I don't know if it really happens) with block or delete button.

Could anybody find out why it happen? Thanks for fixing.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 21 2016, 10:12 AM
Dvorapa updated the task description. (Show Details)Apr 21 2016, 11:08 AM
Dvorapa updated the task description. (Show Details)
Dvorapa added a subscriber: Dvorapa.
Restricted Application added a subscriber: Malyacko. · View Herald TranscriptApr 26 2016, 6:14 PM

Scribunto modules do not support redirects, so any time they are moved redirects will always be suppressed by the software.

So I guess the question is, should we require the suppressredirect when moving pages with a content model that doesn't support redirects

Jackmcbarn closed this task as Invalid.Apr 26 2016, 6:20 PM
Jackmcbarn added a subscriber: Jackmcbarn.

As legoktm said, this happens because it's currently impossible to create a module redirect. Rest assured that this will never allow unauthorized users to access the block or delete buttons. (Also, my personal opinion is that suppressredirect should not be required to move modules, etc.)

I thought that this is bug but it seems that this is a feature.

Can we add support for redirs in modules like in templates? Or disable redirs in templates too. I think that if somebody wants to change name of module, he move it and then he requests bot's owners to change name of module in templates so the redir is useful for small amount of time.

@Jackmcbarn: Why? Why we can't create a module redir but we can create template redir?

@Urbanecm Support for that is requested in T120794.

Thanks for link. Do you know when it'll be approximately set?