Page MenuHomePhabricator

Flow changes not showing in Contributions locally
Closed, InvalidPublic

Description

It seems to work on MediaWiki.org. Haven't isolated the cause yet locally.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 22 2016, 5:16 AM
Mattflaschen-WMF triaged this task as Unbreak Now! priority.Apr 22 2016, 5:17 AM
Mattflaschen-WMF closed this task as Invalid.Apr 25 2016, 11:58 PM

Not an actual bug. Just accidental inconsistent state from old local External Store tests, fixed now.

It does abort the whole hook (including other hooks, but without breaking standard content) if there is a MWException. That is different from how FlowException is handled (that just cancels the individual bad row), but that may be intentional. In this case, it was good since it made the exception more obvious.