Page MenuHomePhabricator

Collapsed entries on Watchlist and Recent Changes cannot be uncollapsed (if the user language is Portuguese)
Closed, InvalidPublic

Description

Steps to reproduce

  1. Enable the preference "Group changes by page in recent changes and watchlist"
  2. Access Special:Log/delete and add three of the most recently deleted pages to your watchlist
  3. Go to Special:Watchlist?uselang=pt

Expected result
The logs are grouped and collapsed in a single line, and there is a triangle on the left to allow you to expand the collapsed content. This is what happens if you change the user language to English (en):
https://pt.wikipedia.org/wiki/Special:Watchlist?uselang=en

Actual result
The logs are grouped and collapsed in a single line, BUT there is NO way to expand the collapsed content.

For some reason, the links to show the hidden lines on Watchlist is not visible for users of Portuguese wikis who use the default language (pt).

The problem does not happens on English Wikipedia anymore, only on ptwiki (maybe others too). Tested with Firefox.

Event Timeline

He7d3r created this task.Apr 26 2016, 1:23 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 26 2016, 1:23 PM
Danny_B added a subscriber: Danny_B.

Can't reproduce, works for me.

Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptMay 1 2016, 7:14 PM
He7d3r removed a project: TestMe.May 1 2016, 8:08 PM
He7d3r updated the task description. (Show Details)

@Danny_B: tested and confirmed it is still broken.

He7d3r updated the task description. (Show Details)May 1 2016, 8:13 PM

Compare a snippet of the HTML source of a working watchlist (English):

<tr>
		<td>
			<span tabindex="0" class="mw-collapsible-toggle mw-collapsible-arrow mw-enhancedchanges-arrow mw-enhancedchanges-arrow-space mw-collapsible-toggle-collapsed"></span>
		</td>
		<td class="mw-enhanced-rc">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;20:01&nbsp;</td>
		<td>
			
			<span class="mw-rc-unwatched">(<a href="/wiki/Especial:Registo/delete" title="Especial:Registo/delete">Deletion log</a>)</span><span class="mw-changeslist-separator">. .</span>
			
			<span class="changedby">[<a href="/wiki/Usu%C3%A1rio:%C3%96nni" title="Usuário:Önni" class="mw-userlink">Önni</a>‎ (3×)]</span>
			
		</td>
	</tr>

with the one from the broken watchlist (Portuguese)

<tr>
		<td>
			<span class="mw-collapsible-toggle mw-collapsible-arrow mw-enhancedchanges-arrow mw-enhancedchanges-arrow-space"></span>
		</td>
		<td class="mw-enhanced-rc">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;20h01min&nbsp;</td>
		<td>
			
			<span class="mw-rc-unwatched">(<a href="/wiki/Especial:Registo/delete" title="Especial:Registo/delete">Registo de eliminações</a>)</span><span class="mw-changeslist-separator">. .</span>
			
			<span class="changedby">[<a href="/wiki/Usu%C3%A1rio:%C3%96nni" title="Usuário:Önni" class="mw-userlink">Önni</a>‎ (3×)]</span>
			
		</td>
	</tr>
TheDJ added a subscriber: TheDJ.May 1 2016, 11:47 PM

There is a div opened somewhere in a message that is not being closed, which is probably confusing the script.. I haven't found which Message is causing it however.

@He7d3r : Thanks for confirming. I've tried it according to the original task description and it worked...

Danny_B closed this task as Invalid.May 4 2016, 3:57 AM

@He7d3r Please close tasks when you perform the action which makes them resolved. Thank you.

Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptMay 4 2016, 3:57 AM

Ok, but what about the underlying problem: should MediaWiki code be susceptible to this kind of bug due to a user editing an interface message?

Dalba added a subscriber: Dalba.Aug 9 2016, 7:07 PM