Create Wikipedia Jamaican
Closed, ResolvedPublic

Description

The language committee has approved the creation of Wikipedia Jamaican.

https://meta.wikimedia.org/wiki/Requests_for_new_languages/Wikipedia_Jamaican

Language code: jam
Site URL: jam.wikipedia.org
Project name: Wikipidia
Project namespace: Wikipidia
Project talk namespace: Wikipidia diskoshan
Project logo: https://commons.wikimedia.org/wiki/File:Wikipedia-logo-v2-jam.svg
Timezone: UTC-5

Local file uploads: disabled

Thank you.

There are a very large number of changes, so older changes are hidden. Show Older Changes
Dzahn added a comment.May 3 2016, 4:36 AM

"Please do not start editing this new site. This site has a test project on the Wikimedia Incubator (or on the Beta Wikiversity or on the Old Wikisource) and it will be imported to here."

Dzahn added a comment.May 3 2016, 4:38 AM

@Mtherwjs please don't just re-close after Krenair already explained it's not quite done yet. it's in the process of being created. several patches are needed.

Mtherwjs closed this task as Resolved.May 3 2016, 4:44 AM
Mtherwjs closed this task as Resolved.May 3 2016, 4:50 AM
Dzahn changed the edit policy from "All Users" to "Custom Policy".EditedMay 3 2016, 5:04 AM
Dzahn reopened this task as Open.

@Mtherwjs nope :)

DSsfduhi3 closed this task as Resolved.May 3 2016, 5:05 AM
Dzahn changed the edit policy from "Custom Policy" to "Custom Policy".May 3 2016, 5:07 AM
Aklapper reopened this task as Open.May 3 2016, 7:57 AM

I will setup labs replication ASAP (production side).

I set up labs replication filters.

Change 286553 abandoned by Alex Monk:
Add jamwiki to restbase and labs DNS configs

Reason:
Just noticed this is actually a duplicate of Idd6582be

https://gerrit.wikimedia.org/r/286553

Change 286278 merged by BBlack:
Add jam.wikipedia to RESTBase and Labs dnsrecursor

https://gerrit.wikimedia.org/r/286278

Change 286555 merged by jenkins-bot:
Update cached SiteMatrix, mainly for jamwiki

https://gerrit.wikimedia.org/r/286555

Change 286556 merged by jenkins-bot:
Add jamwiki messages

https://gerrit.wikimedia.org/r/286556

Just waiting for labs replication to start working now...

Actually, maybe I was wrong: https://jam.wikipedia.org/api/rest_v1/page/html/User%3AKrenair%2Fsandbox?redirect=false

{"type":"https://mediawiki.org/wiki/HyperSwitch/errors/not_found","title":"Not found.","method":"get","uri":"/jam.wikipedia.org/v1/page/html/User%3AKrenair%2Fsandbox"}

Mentioned in SAL [2016-05-04T20:08:44Z] <subbu> finished deploying parsoid sha b0d015fa (T134017)

Krenair added a subscriber: Volans.May 4 2016, 8:35 PM

@jcrespo/@Volans: I think we need a maintain-replicas.pl run?

@Krenair You should ping labs admins.

Nikki added a subscriber: Nikki.May 9 2016, 6:14 AM
Multichill added subscribers: VIGNERON, Multichill.

Did you guys do the Wikidata specific magic? @VIGNERON reported at the Wikidata Village Pump that he is unable to add a link to the "jamwiki". I checked and I was unable to do so too.

Krenair added subscribers: aude, hoo.May 9 2016, 8:45 PM

Pretty sure I ran the site table update script. @hoo/@aude ?

FWIW, I couldn't add one this afternoon (EDT) either.

hoo added a comment.May 9 2016, 10:44 PM

Pretty sure I ran the site table update script. @hoo/@aude ?

On all Wikidata clients (all Wikipedias, Commons, Wikidata itself, …)?

I think I ran the script on aawiki with --site-group wikipedia --force-protocol https

hoo added a comment.May 9 2016, 11:17 PM

I think I ran the script on aawiki with --site-group wikipedia --force-protocol https

It needs to be run across all Wikimedia-Wikis, but beware the comments on https://wikitech.wikimedia.org/wiki/Add_a_wiki#Wikidata, that script once broke parsing on enwiki for a few minutes.

I don't think addWiki runs it across all wikis. I wouldn't be comfortable with it doing that anyway given the potential for breaking other wikis. But I also don't want to end every wiki creation by opening new tickets to finish off the job.

aude added a comment.May 10 2016, 12:24 AM

ran the script on test.wikidata, test2wiki, etc. and have some backups of the tables. now can try running it for other wikis

aude added a comment.May 10 2016, 1:18 AM

ran the script on all wikis in wikidataclient.dblist

I can already add jamwiki site links on test.wikidata. It might take up to an hour (due to caching) before they can be added on Wikidata.

Nikki added a comment.May 10 2016, 9:51 AM

I can add jamwiki links using QuickStatements (e.g. https://www.wikidata.org/w/index.php?diff=334730538) but if I try and do it on Wikidata itself, it doesn't find anything for "jam" and won't give me an input field to enter the page name. I tried a forced refresh and I tried clearing local storage like suggested on https://www.wikidata.org/wiki/Wikidata:Contact_the_development_team/Archive/2016/02#Add_support_for_ady: but still no luck. :/

I can confirm. It still doesn't work in the UI for me either.

I've also noticed that there are a lot of pages not appearing in the categories they're supposed to be in (compare these search results with what is shown in the category itself) and a lot of pages which have templates showing up as red links. Doing a null edit on a page fixes it for that page, is there a script which can be run to fix it for all of them?

https://www.wikidata.org/w/index.php?title=Q889&curid=1211&diff=334725206&oldid=333223017 looks promising, but I don't see jamwiki in the interface yet. It does show up at https://www.wikidata.org/w/api.php?action=help&modules=wbsetsitelink now (interesting way of sorting btw)

I've also noticed that there are a lot of pages not appearing in the categories they're supposed to be in (compare these search results with what is shown in the category itself) and a lot of pages which have templates showing up as red links. Doing a null edit on a page fixes it for that page, is there a script which can be run to fix it for all of them?

T117332: Links tables are sometimes not being populated?

Change 288097 had a related patch set uploaded (by Aude):
Add ady and jam to interwiki sort orders

https://gerrit.wikimedia.org/r/288097

Possibly, although it seems like I'm seeing two things because purging the page will fix any templates or normal links which are incorrectly showing up as red links, but only a null edit fixes the categories.

aude added a comment.May 10 2016, 10:04 PM

@Multichill sounds like a caching issue. Does it work for you in the interface with debug=true?

@aude: It does show up for me if I add ?debug=true to the URL

It looks like things are coming along. Somebody also needs to deal with language hierarchies in the Babel extension. I can manually add "|jam-x" to Babel on any page. However, when I look at my global user page while on jamwiki, it is not providing "jam-0" (or anything else) in response to my coding for {{int:lang}}-0.

Dzahn added a comment.May 11 2016, 6:16 PM

After this ticket is done we should really make one ultimate master list that lists each and every step needed for creating a Wikipedia, from step 1 by adding it in DNS to the very last thing in an extension, all in one place. With checkboxes to go through next time / phabricator template /something.

We already have wikitech:Add_a_wiki, but people like to add additional steps without documenting them there.

It looks like things are coming along. Somebody also needs to deal with language hierarchies in the Babel extension. I can manually add "|jam-x" to Babel on any page. However, when I look at my global user page while on jamwiki, it is not providing "jam-0" (or anything else) in response to my coding for {{int:lang}}-0.

The {{int:lang}} thing is a feature (or bug?) you have to enable yourself. See meta: https://meta.wikimedia.org/w/index.php?title=Special%3APrefixIndex&prefix=Lang&namespace=8

You have to create https://jam.wikipedia.org/wiki/MediaWiki:Lang with contents "jam" and create subpages for all the languages, so for example https://jam.wikipedia.org/wiki/MediaWiki:Lang/fr with contents "fr".

Nikki added a comment.May 13 2016, 2:40 PM

In the description, it says the project namespace should be called "Wikipidia", but on jam.wikipedia.org it seems to still be "Wikipedia"

Change 288628 had a related patch set uploaded (by Alex Monk):
Set meta namespace names for jamwiki

https://gerrit.wikimedia.org/r/288628

Change 288628 merged by jenkins-bot:
Set meta namespace names for jamwiki

https://gerrit.wikimedia.org/r/288628

Portal namespace

During the life on Incubator, a portal namespace have been prepared for Jamaica, https://jam.wikipedia.org/wiki/Puotal:Jumieka

T135479 takes care to transform that into a namespace.

Core namespaces

Localisation in MediaWiki core is still missing, I've seen a lot of "talk" instead of "diskoshan".

StevenJ81 added a comment.EditedMay 24 2016, 1:20 PM

I've tried playing with this language in the drop-downs of multilingual projects like Meta and Wikidata. On Wikidata, where the Babel box's header and footer change languages when you alter the interface language, jam works for that purpose. But at both Wikidata and Meta I have coding in my Babel box that should add jam-0 when I change the interface language. But that doesn't work. (It does work in general. (Test, say, Hindi.) Any thought as to why that might be?

(Note: this is relevant to the project because my meta page is my user page on jamwiki, and I'd like it to show jam-0 there.)

Change 288097 merged by jenkins-bot:
Add ady and jam to interwiki sort orders

https://gerrit.wikimedia.org/r/288097

Dzahn added a comment.Jun 2 2016, 11:36 PM

What is still missing for this task to be resolved now?

StevenJ81 added a comment.EditedJun 3 2016, 12:18 AM

See my comment just above (3rd comment above this).

One thing that needs to be done, apparently, on jamwiki, is to create MediaWiki:Lang with the content "jam". But do all those language subpages need to be created, or can they be automatically generated?

That still doesn't answer the question as to how to make jam work on multilingual projects.

Still need the replica database and views created. I'm waiting for ops to run their script for this.

RobH added a subscriber: RobH.EditedJun 16 2016, 4:55 PM

So I've chatted with @jcrespo and the production side db stuff is done. There has to be some update run in labs, but there is confusion regarding is implementation.

Another identical issue to this is on T135029. T135029#2304213 outlines the issue.

I'll make sure this is listed under blockers for our Monday Ops team meeting.

Dzahn changed the task status from Open to Stalled.Jun 21 2016, 3:30 AM

This is now done, right?

No, i don't think it is done. Still what Rob described above.

jcrespo added a comment.EditedJun 23 2016, 12:01 PM

@Dzahn check your mail [Note: I did not sent him any private email, just pointed him to a discussion where this is supposed to have been fixed, which I believe it is- although I have not personally checked].

Discovery should confirm it, I suppose.

Krenair closed this task as Resolved.Jun 23 2016, 2:05 PM
Krenair claimed this task.

Yes, this appears to be complete now.

Meno25 removed a subscriber: Meno25.Aug 28 2016, 8:06 AM