Page MenuHomePhabricator

decom argon
Closed, ResolvedPublic

Description

argon was irc.wikimedia.org until T123729

after a grace period .. it can be shut down and decom'ed

Details

Related Gerrit Patches:
operations/dns : masterremove argon's public IP
operations/puppet : productionremove argon from site.pp and install_server

Event Timeline

Dzahn created this task.May 3 2016, 1:32 AM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptMay 3 2016, 1:32 AM
Krenair added a subscriber: Krenair.May 3 2016, 1:45 AM
Dzahn triaged this task as Medium priority.May 3 2016, 2:24 AM
Dzahn added a comment.May 9 2016, 6:45 PM

as of today we had ~ 96 users left on the old server and 191 users on the new server

after merging the last 2 ircd config changes i restarted ircd on the old server and right after we have now 293 users on new server, so confirmed that pretty much all of them reconnected automatically and are now migrated to new server

Dzahn added a comment.May 9 2016, 6:46 PM

I will proceed shutting this down..

Change 287685 had a related patch set uploaded (by Dzahn):
remove argon from site.pp and install_server

https://gerrit.wikimedia.org/r/287685

Change 287685 merged by Dzahn:
remove argon from site.pp and install_server

https://gerrit.wikimedia.org/r/287685

Change 287764 had a related patch set uploaded (by Dzahn):
remove argon's public IP

https://gerrit.wikimedia.org/r/287764

Change 287764 merged by Dzahn:
remove argon's public IP

https://gerrit.wikimedia.org/r/287764

Dzahn closed this task as Resolved.May 9 2016, 10:06 PM

done from puppet and DNS point of view. hardware decom in subtask

Krinkle added a subscriber: Krinkle.EditedMay 10 2016, 1:14 PM

MediaWiki production is still sending UDP packets to argon's old IP on every event. Fixed in 7be1ed68374a2cb4204fddc884fd801f95f14339.

Please look for mentions of argon first (would've matched that wmf-config/ProductionServices still referenced argon as the primary).

Other mentions (only dns and a puppet comment), https://github.com/search?q=argon+@wikimedia&type=Code&ref=searchresults

Dzahn added a comment.May 10 2016, 2:02 PM

@Krinkle there was alread https://gerrit.wikimedia.org/r/#/c/287797/ which i was aware of and +1ed

Dzahn added a comment.EditedMay 10 2016, 2:04 PM

The mentions on DNS is the mgmt interface for T134826 and as intended.