Page MenuHomePhabricator

Special:GlobalRenameProgress throws LogicException
Closed, ResolvedPublic

Description

Details

Related Gerrit Patches:

Event Timeline

Pidlisnuk created this task.May 4 2016, 8:59 PM
Restricted Application added subscribers: Zppix, Base, Steinsplitter, Aklapper. · View Herald Transcript
Luke081515 triaged this task as Unbreak Now! priority.May 4 2016, 9:47 PM
Restricted Application added subscribers: Luke081515, TerraCodes, Urbanecm. · View Herald TranscriptMay 4 2016, 9:47 PM
K6ka added a subscriber: K6ka.May 4 2016, 10:03 PM
Savh added a subscriber: Savh.May 4 2016, 10:15 PM

It seems (according to CentralAuth) that that specific rename has been completed, but the issue with the GlobalRenameProgress page remains.

https://meta.wikimedia.org/wiki/Special:CentralAuth/Maksatuly1995

Glaisher renamed this task from Error global renaming user to Special:GlobalRenameProgress throws LogicException.May 5 2016, 9:44 AM

Reproducible locally:

[0f42ef75669d91261d07550c] /wiki/index.php/Special:GlobalRenameProgress?username=A&redirectparams= LogicException from line 1489 of /var/www/html/wiki/includes/htmlform/HTMLForm.php: HTMLForm::displaySection() called on uninitialized field data. You probably called displayForm() without calling prepareForm() first.

Change 287068 had a related patch set uploaded (by Glaisher):
SpecialGlobalRenameProgress: call prepareForm() before displayForm()

https://gerrit.wikimedia.org/r/287068

So the rename was actually successful but this is because of a problem with the special page code.

Change 287068 merged by jenkins-bot:
SpecialGlobalRenameProgress: call prepareForm() before displayForm()

https://gerrit.wikimedia.org/r/287068

Sethakill closed this task as Resolved.May 8 2016, 11:29 AM
Sethakill assigned this task to Glaisher.
Sethakill removed a project: Patch-For-Review.
NMaia reopened this task as Open.May 12 2016, 12:41 PM
NMaia added a subscriber: NMaia.

This is still happening. I've had it happen to myself and I saw it happen to another user as well.

The patch was merged on May 5th. I'm not aware of a SWAT deployment (backporting to 1.27).
Hence the fix should be included in 1.28.0-wmf.1 which is not deployed on all wikis yet: https://www.mediawiki.org/wiki/MediaWiki_1.28/Roadmap

Krenair closed this task as Resolved.May 12 2016, 4:11 PM
Krenair added a subscriber: Krenair.

Confirmed, this task appears to be resolved - the fix may not have been applied to $favouritewiki yet - that depends on the wiki's updating process which is separate to MediaWiki development

Change 299893 had a related patch set uploaded (by Gergő Tisza):
SpecialGlobalRenameProgress: call prepareForm() before displayForm()

https://gerrit.wikimedia.org/r/299893

Change 299893 merged by jenkins-bot:
SpecialGlobalRenameProgress: call prepareForm() before displayForm()

https://gerrit.wikimedia.org/r/299893

NMaia removed a subscriber: NMaia.Jul 20 2016, 12:47 AM
MarcoAurelio moved this task from Backlog to Closed on the GlobalRename board.Oct 11 2016, 1:12 PM
Restricted Application added a subscriber: Jay8g. · View Herald TranscriptOct 11 2016, 1:12 PM
mmodell changed the subtype of this task from "Task" to "Production Error".Aug 28 2019, 11:10 PM