Page MenuHomePhabricator

some pic of graph can't loading?
Closed, ResolvedPublic

Event Timeline

Shizhao created this task.May 5 2016, 2:47 AM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptMay 5 2016, 2:47 AM
Shizhao triaged this task as High priority.May 5 2016, 2:48 AM
Danny_B added a subscriber: Danny_B.

WFM.

Please clear your browser cache and test again. Also please provide versions of browser and OS you use. Thank you.

Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptMay 5 2016, 6:41 PM
Yurik added subscribers: Smalyshev, Yurik.EditedMay 5 2016, 7:04 PM

This could possibly be related to an issue with the wikidata query service that we had today. cc: @Smalyshev T134238

WDQS is fine now, so probably not that. Also I see the queries work fine on the demo page. In any case, static images are supposed to be cached, so they should be showing up even when WDQS is down.

Works for me. (Windows XP, Service Pack 3 | Chrome 49.0.2623.112 m)

Yurik added a comment.May 6 2016, 1:40 AM

I just noticed that it seems graphs are not being cached - T134542, which may be the culprit.

Aklapper raised the priority of this task from High to Needs Triage.Oct 11 2016, 10:03 AM

Bumping

@TerraCodes: Please avoid contentless pinging.
If you have a specific question, please ask it. If you ask a specific person, please mention their name. Thanks.

I was going to ask if this was fixed, but the Largest cities graph isn't showing for me so I'm guessing it isn't fixed.

On https://www.mediawiki.org/wiki/Extension:Graph/Demo/Sparql , "Largest Cities" image only loads for me after bypassing the browser cache.

Now does that make this task solved or not? :P

Yurik added a comment.Oct 13 2016, 3:59 PM

I wonder if this is an issue with the wikidata query timing out? CC @Smalyshev

@Yurik The query works for me. Maybe bad result was cached somewhere?

that page frequently shows broken images, i wonder what's causing it...

I was going to ask if this was fixed, but the Largest cities graph isn't showing for me so I'm guessing it isn't fixed.

I loaded the webpage, the graphs were fine, even the largest cities graph.
Windows 7 Ultimate, Service Pack 1
Chrome Version 53.0.2785.143 m
See screenshot:

Aklapper closed this task as Resolved.Dec 3 2016, 2:35 PM

I loaded the webpage, the graphs were fine, even the largest cities graph.

Indeed, this looks fixed. Thanks for retesting (and providing good info which browser and OS you used)!
Closing this task; please reopen if anyone can still reproduce.