Page MenuHomePhabricator

Convert Special:MergeHistory to OOUI
Open, NormalPublic

Description

Screenshot

BeforeAfter

Event Timeline

Sethakill created this task.May 8 2016, 9:07 AM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptMay 8 2016, 9:07 AM
Sethakill triaged this task as Normal priority.May 8 2016, 9:08 AM
Sethakill moved this task from Unsorted to Conversion to OOUI on the UI-Standardization board.

Change 287435 had a related patch set uploaded (by Sethakill):
Convert Special:MergeHistory to use OOUI.

https://gerrit.wikimedia.org/r/287435

Change 287435 merged by jenkins-bot:
Convert Special:MergeHistory to use OOUI.

https://gerrit.wikimedia.org/r/287435

Sethakill closed this task as Resolved.May 10 2016, 8:29 PM
Sethakill removed a project: Patch-For-Review.

Hi @Sethakill. I just used this tool for the first time since your change here went live. I'm not sure exactly how to word this, but is there any chance that we could go back to if no revision/button is selected and I hit "merge revisions" it just merges all the revisions? This is I think how it used to be and also how it works for undeletions (i.e. it's assumed you want all of it unless you specify otherwise).

I'm not sure if what I'm asking for is a simple or difficult change. Also wasn't sure if I should create a new bug or just comment on this one, please let me know if I need to do anything differently.

Hi @Jenks24 I'd suggest creating a new bug trying to explain replication steps. Can you add some screenshots too?

e.g.
Open page X
Click radio button next to this item.
Expected: This should happen which makes me happy
Actual: This happens which makes me sad

@Sethakill Again a before screenshot would be appreciated (after @Jdlrobson added the after already), please! That'd be beneficial for all 'Conversion to OOjs UI' tasks. We want to make sure from design and UX perspective that the changes are not introducing experience regressions.

Volker_E updated the task description. (Show Details)Jun 20 2016, 5:24 PM
Sethakill updated the task description. (Show Details)Jun 23 2016, 12:03 PM
Sethakill removed a subscriber: gerritbot.

Sorry about troubles. I will set new patch in a moment.

Change 302092 had a related patch set uploaded (by Sethakill):
Convert Special:MergeHistory to use OOUI.

https://gerrit.wikimedia.org/r/302092

Not to forget about when form is transformed from HTMLForm to OOUI: First button should not be a primary button, but solely a progressive one.

Volker_E updated the task description. (Show Details)Nov 11 2018, 12:52 AM