Page MenuHomePhabricator

Re-using a reference is slow for articles with very large numbers of references
Closed, ResolvedPublic8 Story Points

Description

Take a long-ish article - Obama, https://en.wikipedia.org/wiki/Death_metal, you choose.
Try and re-use a reference.
Here's what I observed -albeit sporadically:

  1. it takes a lot for the Cite menu to even come up;
  2. after searching for a reference to re-use, click on it: it isn't added to the article, and you can't go past the search results;
  3. clicking on Cancel also doesn't seem to accomplish any effect.

After point 2 in a different attempt I tried to click on a random link on the page - that worked, in that the dialog disappeared and the reference was where I meant to place it.
Another user says they get a warning from Firefox about a script being slow/unresponsive while trying to add a citation.

Event Timeline

Elitre created this task.May 11 2016, 8:32 AM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptMay 11 2016, 8:32 AM
Elitre updated the task description. (Show Details)May 11 2016, 8:49 AM

I couldn't reproduce 2/3 but it is slow to build the long list, although we may already have a bug for that.

Jdforrester-WMF renamed this task from Re-using a reference is broken-ish for long articles? to Re-using a reference is slow for articles with very large numbers of references.May 24 2016, 7:12 PM
Jdforrester-WMF triaged this task as Low priority.
Jdforrester-WMF set the point value for this task to 8.
Jdforrester-WMF moved this task from To Triage to Freezer on the VisualEditor board.

Change 320000 had a related patch set uploaded (by Esanders):
Use shallow copy for internal list data inside shallowCloneFromRange

https://gerrit.wikimedia.org/r/320000

Change 320002 had a related patch set uploaded (by Esanders):
Re-use internalList when building index

https://gerrit.wikimedia.org/r/320002

Change 320006 had a related patch set uploaded (by Esanders):
Avoid jQuery in PreviewElement and ve.resolveAttributes

https://gerrit.wikimedia.org/r/320006

Change 320002 merged by jenkins-bot:
Re-use internalList when building index

https://gerrit.wikimedia.org/r/320002

Change 320000 merged by jenkins-bot:
Use shallow copy for internal list data inside shallowCloneFromRange

https://gerrit.wikimedia.org/r/320000

Change 320006 merged by jenkins-bot:
Avoid jQuery in PreviewElement and ve.resolveAttributes

https://gerrit.wikimedia.org/r/320006

Jdforrester-WMF added a subscriber: Jdforrester-WMF.

Ed, do you think we should keep this open or deem it Resolved?

Well - it's still ~500ms for a long article (200 refs), so debatable.

Esanders closed this task as Resolved.Aug 24 2018, 10:24 AM
Esanders claimed this task.
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptAug 24 2018, 10:24 AM