Page MenuHomePhabricator

videojs source switcher should not offer unplayable sources which break the player when selected
Closed, ResolvedPublic

Description

Currently in videojs mode, the source switcher offers sources that cannot be played. Selecting them puts the video player into a broken state where you cannot switch back to another source.

Example: in Safari, ogv.js offers to play back the ogg sources but nothing can play the webm sources.

Expected behavior: unplayable sources are not listed.

Event Timeline

brion created this task.May 11 2016, 5:43 PM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptMay 11 2016, 5:43 PM
TheDJ triaged this task as Medium priority.May 11 2016, 8:13 PM
TheDJ added a subscriber: TheDJ.

This is currently hold up a bit due to non-responsiveness of the upstream plugin maintainer..

Considering forking, or at least running against the git of my fork.

TheDJ moved this task from To sort to Player on the TimedMediaHandler board.

Maybe as a short term solution we can get upstream videojs to allow us to switch sources even when we click on one that carn't be played in the current browser.

TheDJ moved this task from Backlog to Video.js on the Kaltura player board.May 13 2016, 11:53 AM
TheDJ claimed this task.May 23 2016, 9:37 PM
TheDJ moved this task from Player to Doing on the TimedMediaHandler board.

I updated the resource selector here https://gerrit.wikimedia.org/r/#/c/304021/ and it includes your patch, and un playable sources are no longer shown.

Can we close this task as resolved please?

brion closed this task as Resolved.Oct 4 2016, 7:52 PM

Closing as resolved per above.